Marked prior to version 0.3.17 is vulnerable to a Regular Expression Denial of Service (ReDoS) attack due to catastrophic backtracking in several regular expressions used for parsing HTML tags and markdown links.
CVSS 4.0MEDIUM 6.9·Network·No auth·No interaction·EPSS 0.0061·Published 2025-05-23·Fixed in 0.3.17CWE-1333
The marked package before 0.3.4 for Node.js allows attackers to cause a denial of service (CPU consumption) via unspecified vectors that trigger a "catastrophic backtracking issue for the em inline rule," aka a "regular…
CVSS 3.1HIGH 7.5·Network·No auth·No interaction·EPSS 0.04417·Published 2017-01-23·Fixed in 0.3.4CWE-1333
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2)…
CVSS 3.1MEDIUM 6.1·Network·No auth·User interaction·EPSS 0.01715·Published 2020-01-06·Fixed in 0.3.1CWE-79
Incomplete blacklist vulnerability in marked 0.3.2 and earlier for Node.js allows remote attackers to conduct cross-site scripting (XSS) attacks via a vbscript tag in a link.
CVSS 2.0MEDIUM 4.3·Network·No auth·Interaction —·EPSS 0.02042·Published 2015-01-27·Fixed in 0.3.3CWE-79