Logstash prior to version 2.3.4, Elasticsearch Output plugin would log to file HTTP…
Priority LOW 36CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Logstash prior to version 2.3.4, Elasticsearch Output plugin would log to file HTTP authorization headers which could contain sensitive information.
Why it matters now
EPSS 0.01782 78th percentileScored 2026-11-07
Fix Fixed logstash-core (RubyGems): 2.3.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | logstash-core (RubyGems) | before 2.3.4 | 2.3.4 | Patch available | GHSA-vcmm-ppqx-95ch |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- logstash-core (RubyGems) Vendor— Affected before 2.3.4 Fixed in 2.3.4 Patch available GHSA-vcmm-ppqx-95ch
Remediation
- Fix · GHSA-vcmm-ppqx-95ch logstash-core (RubyGems) Fixed in 2.3.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-1000221
- 2026-10-03 Alias added: GHSA-vcmm-ppqx-95ch
References
Advisory 2
More Elastic Logstash vulnerabilities
- TI-2019-05366 Information disclosure through error messages in Elastic Logstash CVSS 3.1CRITICAL 9.8
- TI-2026-25862 Improper Limitation of a Pathname to a Restricted Directory in Logstash Leading to Arbitrary File Write CVSS 3.1CRITICAL 9.8
- TI-2014-03539 Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to… CVSS 2.0HIGH 7.5
- TI-2015-04531 Logstash 1.5.x before 1.5.3 and 1.4.x before 1.4.4 allows remote attackers to read… CVSS 3.0HIGH 7.5
- TI-2019-05374 Uncontrolled resource consumption in Elastic Logstash CVSS 3.1HIGH 7.5
- TI-2023-25173 Logstash Insertion of Sensitive Information into Log File CVSS 3.1HIGH 8.4
Sources
- CVE-2016-1000221 · CVE Program
- CVE-2016-1000221 · NVD
- FIRST EPSS
- GHSA-vcmm-ppqx-95ch · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences