Versions of Puppet Enterprise prior to 2016.4.5 or 2017.2.1 shipped with an MCollective…
Priority LOW 24Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
Versions of Puppet Enterprise prior to 2016.4.5 or 2017.2.1 shipped with an MCollective configuration that allowed the package plugin to install or remove arbitrary packages on all managed agents. This release adds default configuration to not allow these actions. Customers who rely on this functionality can change this policy.
Why it matters now
EPSS 0.00688 52nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Puppet | Puppet Enterprise | prior to 2016.4.5, 2016.5.x, 2017.1.x, resolved in 2016.4.5 and 2017.2.1 | — | No fix listed | CNA |
- Puppet Enterprise VendorPuppet Affected prior to 2016.4.5, 2016.5.x, 2017.1.x, resolved in 2016.4.5 and 2017.2.1 Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* | before 2016.4.5 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet_enterprise:2016.5.1:*:*:*:*:*:*:* | 2016.5.1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet_enterprise:2016.5.2:*:*:*:*:*:*:* | 2016.5.2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet_enterprise:2017.1.0:*:*:*:*:*:*:* | 2017.1.0 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet_enterprise:2017.1.1:*:*:*:*:*:*:* | 2017.1.1 | Vulnerable | Puppet |
- cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* Versions before 2016.4.5 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet_enterprise:2016.5.1:*:*:*:*:*:*:* Versions 2016.5.1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet_enterprise:2016.5.2:*:*:*:*:*:*:* Versions 2016.5.2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet_enterprise:2017.1.0:*:*:*:*:*:*:* Versions 2017.1.0 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet_enterprise:2017.1.1:*:*:*:*:*:*:* Versions 2017.1.1 Vulnerable ·Puppet
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2017-2293
- 2026-10-03 Alias added: GHSA-wg8j-wm67-mv7w
References
More Puppet Enterprise vulnerabilities
- TI-2017-05170 Integer overflow in nginx CVSS 3.1HIGH 7.5
- TI-2023-02371 A privilege escalation allowing remote code execution was discovered in the orchestration service. CVSS 3.1CRITICAL 9.8
- TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
- TI-2018-04792 Code injection in Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and… CVSS 3.0CRITICAL 9.8
- TI-2016-02330 MCollective 2.7.0 and 2.8.x before 2.8.9, as used in Puppet Enterprise, allows remote… CVSS 3.0CRITICAL 9.8
- TI-2021-08596 A flaw was discovered in Puppet Agent and Puppet Server that may result in a leak of HTTP… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2017-2293 · CVE Program
- CVE-2017-2293 · NVD
- FIRST EPSS
- GHSA-wg8j-wm67-mv7w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences