Read the docs

Puppet

Records130All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical19CVSS 9.0–10.0
CVSS high30CVSS 7.0–8.9

Exploited now

Puppet records in CISA KEV

No Puppet vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

89 records in Puppet Enterprise · all components

TI-2017-05170 CVE-2017-7529 · GHSA-85mj-h68w-w736

Integer overflow in nginx

Priority HIGH 68

Nginx versions since 0.5.6 up to and including 1.13.2 are vulnerable to integer overflow vulnerability in nginx range filter module resulting into leak of potentially sensitive information triggered by specially crafted…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.62597 Published 2017-07-13 Partial fix CWE-190
Priority MEDIUM 47

The (1) template and (2) inline_template functions in the master server in Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2 allows remote authen…

CVSS 2.0HIGH 9.0 Network Low privileges Interaction — EPSS 0.04927 Published 2013-03-20 Partial fix
Priority MEDIUM 45

The pxp-agent component in Puppet Enterprise 2015.3.x before 2015.3.3 and Puppet Agent 1.3.x before 1.3.6 does not properly validate server certificates, which might allow remote attackers to spoof brokers and execute ar…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01563 Published 2016-06-10 No fix listed CWE-20
TI-2019-07982 CVE-2019-10694 · GHSA-8h2m-rx7g-r9gv

Hard-coded credentials in Puppet Enterprise

Priority MEDIUM 44

The express install, which is the suggested way to install Puppet Enterprise, gives the user a URL at the end of the install to set the admin password.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01089 Published 2019-12-11 No fix listed CWE-798
Priority MEDIUM 43

Versions of Puppet Enterprise prior to 2021.7.6 and 2023.5 contain a flaw which results in broken session management for SAML implementations.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00496 Published 2023-11-07 Fixed in 2021.7.6, 2023.5 CWE-384
Priority MEDIUM 41

A user with specific node group editing permissions and a specially crafted class parameter could be used to execute commands as root on the primary host.

CVSS 4.0HIGH 8.6 Network High privileges No interaction EPSS 0.01098 Published 2025-06-26 No fix listed CWE-78
TI-2021-08594 CVE-2021-27021 · GHSA-j664-pgf6-rhhh

SQL injection in Puppet DB

Priority MEDIUM 41

A flaw was discovered in Puppet DB, this flaw results in an escalation of privileges which allows the user to delete tables via an SQL query.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01262 Published 2021-07-20 No fix listed CWE-1027
Priority MEDIUM 40

Puppet Enterprise 2016.4.x prior to 2016.4.12, Puppet Enterprise 2017.3.x prior to 2017.3.7, Puppet Enterprise 2018.1.x prior to 2018.1.1, Puppet Agent 1.10.x prior to 1.10.13, Puppet Agent 5.3.x prior to 5.3.7, and Pupp…

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.01117 Published 2018-06-11 No fix listed CWE-426
Priority MEDIUM 40

Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2, when listening for incoming connections is enabled and allowing access to the "run" REST endpo…

CVSS 2.0HIGH 7.1 Network Low privileges Interaction — EPSS 0.05375 Published 2013-03-20 No fix listed
Priority MEDIUM 40

The pe_mcollective module in Puppet Enterprise (PE) before 2.7.1 does not properly restrict access to a catalog of private SSL keys, which allows remote authenticated users to obtain sensitive information and gain privil…

CVSS 2.0HIGH 8.5 Network Low privileges Interaction — EPSS 0.01541 Published 2014-03-14 No fix listed CWE-310
Priority LOW 39

Puppet 2.7.x before 2.7.22 and 3.2.x before 3.2.2, and Puppet Enterprise before 2.8.2, deserializes untrusted YAML, which allows remote attackers to instantiate arbitrary Ruby classes and execute arbitrary code via a cra…

CVSS 2.0HIGH 7.5 Network No auth Interaction — EPSS 0.03408 Published 2013-08-19 Partial fix · 2.7.22, 3.2.2 CWE-20
Priority LOW 36

Puppet Enterprise 2015.3.3 and 2016.x before 2016.4.0, and Puppet Agent 1.3.6 through 1.7.0 allow remote attackers to bypass a host whitelist protection mechanism and execute arbitrary code on Puppet nodes via vectors re…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.02241 Published 2017-10-18 No fix listed CWE-284
Priority LOW 35

Versions of Puppet Enterprise prior to 2016.4.5 or 2017.2.1 failed to mark MCollective server private keys as sensitive (a feature added in Puppet 4.6), so key values could be logged and stored in PuppetDB.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.01163 Published 2017-07-05 No fix listed CWE-200
Load more
Open these records in search →