Read the docs
TI-2017-01577 Aliases CVE-2017-2296GHSA-cc93-3xjh-46wh

Improper input validation in Puppet Enterprise

Priority LOW 31CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
No fix listed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA.

Summary

In Puppet Enterprise 2017.1.x and 2017.2.1, using specially formatted strings with certain formatting characters as Classifier node group names or RBAC role display names causes errors, effectively causing a DOS to the service. This was resolved in Puppet Enterprise 2017.2.2.

Why it matters now

EPSS 0.0088 59th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
PuppetPuppet Enterprise2017.1.x, 2017.2.1. Fixed in 2017.2.2—No fix listedCNA
  • Puppet Enterprise VendorPuppet Affected 2017.1.x, 2017.2.1. Fixed in 2017.2.2 Fixed in — No fix listed CNA

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:puppet:puppet_enterprise:2017.1.0:*:*:*:*:*:*:*2017.1.0VulnerablePuppet
cpe:2.3:a:puppet:puppet_enterprise:2017.1.1:*:*:*:*:*:*:*2017.1.1VulnerablePuppet
cpe:2.3:a:puppet:puppet_enterprise:2017.2.1:*:*:*:*:*:*:*2017.2.1VulnerablePuppet
  • cpe:2.3:a:puppet:puppet_enterprise:2017.1.0:*:*:*:*:*:*:* Versions 2017.1.0 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet_enterprise:2017.1.1:*:*:*:*:*:*:* Versions 2017.1.1 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet_enterprise:2017.2.1:*:*:*:*:*:*:* Versions 2017.2.1 Vulnerable ·Puppet

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-2296
  2. 2026-10-03 Alias added: GHSA-cc93-3xjh-46wh

References

  • TI-2017-05170 Integer overflow in nginx CVSS 3.1HIGH 7.5
  • TI-2023-02371 A privilege escalation allowing remote code execution was discovered in the orchestration service. CVSS 3.1CRITICAL 9.8
  • TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
  • TI-2018-04792 Code injection in Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and… CVSS 3.0CRITICAL 9.8
  • TI-2016-02330 MCollective 2.7.0 and 2.8.x before 2.8.9, as used in Puppet Enterprise, allows remote… CVSS 3.0CRITICAL 9.8
  • TI-2021-08596 A flaw was discovered in Puppet Agent and Puppet Server that may result in a leak of HTTP… CVSS 3.1CRITICAL 9.8
See all 88 →

Sources