Improper authentication in Puppet Enterprise
Priority LOW 34CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-287.
Summary
Puppet Enterprise versions prior to 2016.4.5 and 2017.2.1 did not correctly authenticate users before returning labeled RBAC access tokens. This issue has been fixed in Puppet Enterprise 2016.4.5 and 2017.2.1. This only affects users with labeled tokens, which is not the default for tokens.
Why it matters now
EPSS 0.00635 50th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Puppet | Puppet Enterprise | 2016.4.x prior to 2016.4.5, 2016.5.x, 2017.1.x | — | No fix listed | CNA |
- Puppet Enterprise VendorPuppet Affected 2016.4.x prior to 2016.4.5, 2016.5.x, 2017.1.x Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* | before 2016.4.5 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet_enterprise:2016.5.1:*:*:*:*:*:*:* | 2016.5.1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet_enterprise:2016.5.2:*:*:*:*:*:*:* | 2016.5.2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet_enterprise:2017.1.0:*:*:*:*:*:*:* | 2017.1.0 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet_enterprise:2017.1.1:*:*:*:*:*:*:* | 2017.1.1 | Vulnerable | Puppet |
- cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* Versions before 2016.4.5 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet_enterprise:2016.5.1:*:*:*:*:*:*:* Versions 2016.5.1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet_enterprise:2016.5.2:*:*:*:*:*:*:* Versions 2016.5.2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet_enterprise:2017.1.0:*:*:*:*:*:*:* Versions 2017.1.0 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet_enterprise:2017.1.1:*:*:*:*:*:*:* Versions 2017.1.1 Vulnerable ·Puppet
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2017-2297
- 2026-10-03 Alias added: GHSA-86rf-m4cq-ghm6
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
More Puppet Enterprise vulnerabilities
- TI-2017-05170 Integer overflow in nginx CVSS 3.1HIGH 7.5
- TI-2023-02371 A privilege escalation allowing remote code execution was discovered in the orchestration service. CVSS 3.1CRITICAL 9.8
- TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
- TI-2018-04792 Code injection in Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and… CVSS 3.0CRITICAL 9.8
- TI-2016-02330 MCollective 2.7.0 and 2.8.x before 2.8.9, as used in Puppet Enterprise, allows remote… CVSS 3.0CRITICAL 9.8
- TI-2021-08596 A flaw was discovered in Puppet Agent and Puppet Server that may result in a leak of HTTP… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2017-2297 · CVE Program
- CVE-2017-2297 · NVD
- FIRST EPSS
- GHSA-86rf-m4cq-ghm6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences