Read the docs
TI-2017-01851 Aliases CVE-2017-2599GHSA-7r4h-2h23-6jq9

Incorrect authorization in [UNKNOWN] jenkins

Priority LOW 27CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-863.

Summary

Jenkins before versions 2.44 and 2.32.2 is vulnerable to an insufficient permission check. This allows users with permissions to create new items (e.g. jobs) to overwrite existing items they don't have access to (SECURITY-321).

Why it matters now

EPSS 0.01076 65th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.32.2, 2.44Red Hat: 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
[UNKNOWN]jenkinsjenkins 2.44; jenkins 2.32.2—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 2.32.22.32.2Patch availableGHSA-7r4h-2h23-6jq9
—org.jenkins-ci.main:jenkins-core (Maven)2.34 to before 2.442.44Patch availableGHSA-7r4h-2h23-6jq9
  • jenkins Vendor[UNKNOWN] Affected jenkins 2.44; jenkins 2.32.2 Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.32.2 Fixed in 2.32.2 Patch available GHSA-7r4h-2h23-6jq9
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.34 to before 2.44 Fixed in 2.44 Patch available GHSA-7r4h-2h23-6jq9

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*before 2.32.2VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:*before 2.44VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions before 2.32.2 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions before 2.44 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-7r4h-2h23-6jq9 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.32.2 Advisory →
  • Fix · GHSA-7r4h-2h23-6jq9 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.44 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Enterprise 2Affected—
Red Hat OpenShift Enterprise 3Affected—

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-2599
  2. 2026-10-03 Alias added: GHSA-7r4h-2h23-6jq9

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources