Cross-site scripting in jenkins
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting in parameter names and descriptions (SECURITY-353). Users with the permission to configure jobs were able to inject JavaScript into parameter names and descriptions.
Why it matters now
EPSS 0.0203 81st percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.32.2, 2.44Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| unspecified | jenkins | jenkins 2.44; jenkins 2.32.2 | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.32.2 | 2.32.2 | Patch available | GHSA-r69c-5j7c-vm6q |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.34 to before 2.44 | 2.44 | Patch available | GHSA-r69c-5j7c-vm6q |
- jenkins Vendorunspecified Affected jenkins 2.44; jenkins 2.32.2 Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.32.2 Fixed in 2.32.2 Patch available GHSA-r69c-5j7c-vm6q
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.34 to before 2.44 Fixed in 2.44 Patch available GHSA-r69c-5j7c-vm6q
Remediation
- Fix · GHSA-r69c-5j7c-vm6q org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.32.2 Advisory →
- Fix · GHSA-r69c-5j7c-vm6q org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.44 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 2 | Affected | — |
| Red Hat OpenShift Enterprise 3 | Affected | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-2601
- 2026-10-03 Alias added: GHSA-r69c-5j7c-vm6q
References
Patch 2
Advisory 6
- https://jenkins.io/security/advisory/2017-02-01/
- [oss-security] 20220412 Multiple vulnerabilities in Jenkins plugins
- [oss-security] 20220517 Multiple vulnerabilities in Jenkins plugins
- [oss-security] 20220622 Multiple vulnerabilities in Jenkins and Jenkins plugins
- [oss-security] 20220630 Multiple vulnerabilities in Jenkins plugins
- https://nvd.nist.gov/vuln/detail/CVE-2017-2601
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2017-2601 · CVE Program
- CVE-2017-2601 · NVD
- FIRST EPSS
- GHSA-r69c-5j7c-vm6q · GitHub Advisory Database · CC BY 4.0
- CVE-2017-2601 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences