Cross-site scripting in [UNKNOWN] jenkins
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting in search suggestions due to improperly escaping users with less-than and greater-than characters in their names (SECURITY-388).
Why it matters now
EPSS 0.01432 73rd percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.32.2, 2.44Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| [UNKNOWN] | jenkins | jenkins 2.44; jenkins 2.32.2 | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.32.2 | 2.32.2 | Patch available | GHSA-jff5-55xj-4jcq |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.34 to before 2.44 | 2.44 | Patch available | GHSA-jff5-55xj-4jcq |
- jenkins Vendor[UNKNOWN] Affected jenkins 2.44; jenkins 2.32.2 Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.32.2 Fixed in 2.32.2 Patch available GHSA-jff5-55xj-4jcq
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.34 to before 2.44 Fixed in 2.44 Patch available GHSA-jff5-55xj-4jcq
Remediation
- Fix · GHSA-jff5-55xj-4jcq org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.32.2 Advisory →
- Fix · GHSA-jff5-55xj-4jcq org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.44 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 2 | Affected | — |
| Red Hat OpenShift Enterprise 3 | Affected | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-2610
- 2026-10-03 Alias added: GHSA-jff5-55xj-4jcq
References
Advisory 2
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2017-2610 · CVE Program
- CVE-2017-2610 · NVD
- FIRST EPSS
- GHSA-jff5-55xj-4jcq · GitHub Advisory Database · CC BY 4.0
- CVE-2017-2610 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences