Read the docs
TI-2017-01919 Aliases CVE-2017-2673GHSA-j36m-hv43-7w7m

Incorrect authorization in [UNKNOWN] openstack-keystone

Priority LOW 36CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 fixed, 1 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-863.

Summary

An authorization-check flaw was discovered in federation configurations of the OpenStack Identity service (keystone). An authenticated federated user could request permissions to a project and unintentionally be granted all related roles including administrative roles.

Why it matters now

EPSS 0.023 83rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial keystone (PyPI): 10.0.2, 11.0.1Red Hat: 2 advisoriesRed Hat: 2 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
[UNKNOWN]openstack-keystoneall versions—No fix listedCNA
—keystone (PyPI)9.0.0 – 9.3.0—No fix listedGHSA-j36m-hv43-7w7m
—keystone (PyPI)10.0.0 to before 10.0.210.0.2Patch availableGHSA-j36m-hv43-7w7m
—keystone (PyPI)11.0.0 to before 11.0.111.0.1Patch availableGHSA-j36m-hv43-7w7m
  • openstack-keystone Vendor[UNKNOWN] Affected all versions Fixed in — No fix listed CNA
  • keystone (PyPI) Vendor— Affected 9.0.0 – 9.3.0 Fixed in — No fix listed GHSA-j36m-hv43-7w7m
  • keystone (PyPI) Vendor— Affected 10.0.0 to before 10.0.2 Fixed in 10.0.2 Patch available GHSA-j36m-hv43-7w7m
  • keystone (PyPI) Vendor— Affected 11.0.0 to before 11.0.1 Fixed in 11.0.1 Patch available GHSA-j36m-hv43-7w7m

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:redhat:openstack:9:*:*:*:*:*:*:*9VulnerableRed Hat
cpe:2.3:a:redhat:openstack:10:*:*:*:*:*:*:*10VulnerableRed Hat
  • cpe:2.3:a:redhat:openstack:9:*:*:*:*:*:*:* Versions 9 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openstack:10:*:*:*:*:*:*:* Versions 10 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-j36m-hv43-7w7m keystone (PyPI) Fixed in 10.0.2 Advisory →
  • Fix · GHSA-j36m-hv43-7w7m keystone (PyPI) Fixed in 11.0.1 Advisory →

Red Hat 2 advisories

  • RHSA-2017:1597 Released 2017-06-28 · Red Hat rating Important
    openstack-keystone security, bug fix, and enhancement update
    • Red Hat OpenStack Platform 10.0 openstack-keystone-1:10.0.1-3.el7ost, python-keystone-1:10.0.1-3.el7ost, python-keystone-tests-1:10.0.1-3.el7ost
  • RHSA-2017:1461 Released 2017-06-14 · Red Hat rating Moderate
    openstack-keystone security, bug fix, and enhancement update
    • Red Hat OpenStack Platform 9.0 openstack-keystone-1:9.3.0-2.el7ost, python-keystone-1:9.3.0-2.el7ost, python-keystone-tests-1:9.3.0-2.el7ost

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenStack Platform 11 (Ocata)AffectedNo fix yet
Red Hat OpenStack Platform 10.0Fixed RHSA-2017:1597
Red Hat OpenStack Platform 9.0Fixed RHSA-2017:1461
Not affected: 4 products
  • Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse)
  • Red Hat Enterprise Linux OpenStack Platform 6 (Juno)
  • Red Hat Enterprise Linux OpenStack Platform 7 (Kilo)
  • Red Hat OpenStack Platform 8 (Liberty)

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-2673
  2. 2026-10-03 Alias added: GHSA-j36m-hv43-7w7m

References

  • TI-2016-05707 Oracle MySQL through 5.5.52, 5.6.x through 5.6.33, and 5.7.x through 5.7.15; MariaDB… CVSS 3.0CRITICAL 9.8
  • TI-2018-07980 Memory Corruption was discovered in the cmsgpack library in the Lua subsystem in Redis… CVSS 3.0CRITICAL 9.8
  • TI-2020-07599 Apache HTTP Server versions 2.4.20 to 2.4.43. CVSS 3.1HIGH 7.5
  • TI-2019-06950 Some HTTP/2 implementations are vulnerable to a settings flood, potentially leading to a… CVSS 3.1HIGH 7.5
  • TI-2018-15768 Memcached version 1.5.5 contains an Insufficient Control of Network Message Volume… CVSS 3.0HIGH 7.5
  • TI-2019-06949 Some HTTP/2 implementations are vulnerable to a reset flood, potentially leading to a… CVSS 3.1HIGH 7.5
See all 209 →

Sources