There is XSS in SilverStripe CMS before 3.4.4 and 3.5.x before 3.5.2.
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
There is XSS in SilverStripe CMS before 3.4.4 and 3.5.x before 3.5.2. The attack vector is a page name. An example payload is a crafted JavaScript event handler within a malformed SVG element.
Why it matters now
EPSS 0.00761 55th percentileScored 2026-11-07
Fix Fixed silverstripe/cms (Packagist): 3.4.4, 3.5.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | silverstripe/cms (Packagist) | before 3.4.4 | 3.4.4 | Patch available | GHSA-xmjh-wjc5-wg4h |
| — | silverstripe/cms (Packagist) | 3.5.0 to before 3.5.2 | 3.5.2 | Patch available | GHSA-xmjh-wjc5-wg4h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- silverstripe/cms (Packagist) Vendor— Affected before 3.4.4 Fixed in 3.4.4 Patch available GHSA-xmjh-wjc5-wg4h
- silverstripe/cms (Packagist) Vendor— Affected 3.5.0 to before 3.5.2 Fixed in 3.5.2 Patch available GHSA-xmjh-wjc5-wg4h
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:silverstripe:silverstripe:*:*:*:*:*:*:*:* | up to 3.4.3 | Vulnerable | silverstripe |
| cpe:2.3:a:silverstripe:silverstripe:3.5.0:*:*:*:*:*:*:* | 3.5.0 | Vulnerable | silverstripe |
| cpe:2.3:a:silverstripe:silverstripe:3.5.1:*:*:*:*:*:*:* | 3.5.1 | Vulnerable | silverstripe |
- cpe:2.3:a:silverstripe:silverstripe:*:*:*:*:*:*:*:* Versions up to 3.4.3 Vulnerable ·silverstripe
- cpe:2.3:a:silverstripe:silverstripe:3.5.0:*:*:*:*:*:*:* Versions 3.5.0 Vulnerable ·silverstripe
- cpe:2.3:a:silverstripe:silverstripe:3.5.1:*:*:*:*:*:*:* Versions 3.5.1 Vulnerable ·silverstripe
Remediation
- Fix · GHSA-xmjh-wjc5-wg4h silverstripe/cms (Packagist) Fixed in 3.4.4 Advisory →
- Fix · GHSA-xmjh-wjc5-wg4h silverstripe/cms (Packagist) Fixed in 3.5.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-5197
- 2026-10-03 Alias added: GHSA-xmjh-wjc5-wg4h
References
More Silverstripe vulnerabilities
- TI-2007-02239 Unspecified vulnerability in the search functionality in SilverStripe 2.0.0 has unknown impact and attack vectors. CVSS 2.0HIGH 10.0
- TI-2019-09110 In SilverStripe through 4.3.3, a missing warning about leaving install.php in a public… CVSS 3.1CRITICAL 9.8
- TI-2019-04049 All versions of SilverStripe 3 prior to 3.6.7 and 3.7.3, and all versions of SilverStripe… CVSS 3.0CRITICAL 9.8
- TI-2019-09281 In SilverStripe through 4.3.3, the previous fix for SS-2018-007 does not completely… CVSS 3.1HIGH 8.8
- TI-2011-04272 code/sitefeatures/PageCommentInterface.php in SilverStripe 2.4.x before 2.4.6 might allow… CVSS 2.0MEDIUM 6.8
- TI-2020-07421 In SilverStripe through 4.5, files uploaded via Forms to folders migrated from… CVSS 3.1HIGH 7.5
Sources
- CVE-2017-5197 · CVE Program
- CVE-2017-5197 · NVD
- FIRST EPSS
- GHSA-xmjh-wjc5-wg4h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences