Deserialization of untrusted data in Apache Flex Blaze DS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Previous versions of Apache Flex BlazeDS (4.7.2 and earlier) did not restrict which types were allowed for AMF(X) object deserialization by default. During the deserialization process code is executed that for several known types has undesired side-effects. Other, unknown types may also exhibit such behaviors. One vector in the Java standard library exists that allows an attacker to trigger possibly further exploitable Java deserialization of untrusted data. Other known vectors in third party libraries can be used to trigger remote code execution.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Flex Blaze DS | before 4.7.3 | 4.7.3 | Patch available | CNA |
| — | org.apache.flex.blazeds:flex-messaging-core (Maven) | before 4.7.3 | 4.7.3 | Patch available | GHSA-w8v7-prhw-xjpw |
| — | org.apache.flex.blazeds:flex-messaging-remoting (Maven) | before 4.7.3 | 4.7.3 | Patch available | GHSA-w8v7-prhw-xjpw |
- Apache Flex Blaze DS VendorApache Affected before 4.7.3 Fixed in 4.7.3 Patch available CNA
- org.apache.flex.blazeds:flex-messaging-core (Maven) Vendor— Affected before 4.7.3 Fixed in 4.7.3 Patch available GHSA-w8v7-prhw-xjpw
- org.apache.flex.blazeds:flex-messaging-remoting (Maven) Vendor— Affected before 4.7.3 Fixed in 4.7.3 Patch available GHSA-w8v7-prhw-xjpw
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:flex_blazeds:*:*:*:*:*:*:*:* | up to 4.7.2 | Vulnerable | Apache |
| cpe:2.3:a:hp:xp_command_view_advanced_edition:*:*:*:*:*:*:*:* | before 8.5.3-00 | Vulnerable | Hewlett Packard Enterprise |
- cpe:2.3:a:apache:flex_blazeds:*:*:*:*:*:*:*:* Versions up to 4.7.2 Vulnerable ·Apache
- cpe:2.3:a:hp:xp_command_view_advanced_edition:*:*:*:*:*:*:*:* Versions before 8.5.3-00 Vulnerable ·Hewlett Packard Enterprise
Remediation
- Fix · CNA Apache Flex Blaze DS (Apache Software Foundation) Fixed in 4.7.3
- Fix · GHSA-w8v7-prhw-xjpw org.apache.flex.blazeds:flex-messaging-core (Maven) Fixed in 4.7.3 Advisory →
- Fix · GHSA-w8v7-prhw-xjpw org.apache.flex.blazeds:flex-messaging-remoting (Maven) Fixed in 4.7.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-5641
- 2026-10-03 Alias added: GHSA-w8v7-prhw-xjpw
References
Advisory 6
- VU#307983
- https://issues.apache.org/jira/browse/FLEX-35290
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf03823en_us
- https://www.zerodayinitiative.com/advisories/ZDI-22-507/
- https://www.zerodayinitiative.com/advisories/ZDI-22-506/
- https://nvd.nist.gov/vuln/detail/CVE-2017-5641
Other 9
- [flex-dev] 20170327 [VOTE] Release Apache Flex BlazeDS 4.7.3
- https://github.com/apache/flex-blazeds/commit/11b0aa132d9a43bf81fa12654ff227ff247b4627
- https://github.com/apache/flex-blazeds/commit/f861f0993c35e664906609cad275e45a71e2aaf1
- https://github.com/apache/flex-blazeds
- https://web.archive.org/web/20170920093830/http://www.securitytracker.com/id/1038273
- https://web.archive.org/web/20210124021605/http://www.securityfocus.com/bid/97383
- https://www.zerodayinitiative.com/advisories/ZDI-22-506
- https://www.zerodayinitiative.com/advisories/ZDI-22-507
- http://mail-archives.apache.org/mod_mbox/flex-dev/201703.mbox/%[email protected]%3E
Sources
- CVE-2017-5641 · CVE Program
- CVE-2017-5641 · NVD
- FIRST EPSS
- GHSA-w8v7-prhw-xjpw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences