Apache POI in versions prior to release 3.15 allows remote attackers to cause a denial of…
Priority LOW 32CWE-776Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Apache POI in versions prior to release 3.15 allows remote attackers to cause a denial of service (CPU consumption) via a specially crafted OOXML file, aka an XML Entity Expansion (XEE) attack.
Why it matters now
EPSS 0.04595 91st percentileScored 2026-11-07
Fix Fixed Apache POI (Apache Software Foundation): 3.15org.apache.poi:poi (Maven): 3.15
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache POI | before 3.15 | 3.15 | Patch available | CNA |
| — | org.apache.poi:poi (Maven) | before 3.15 | 3.15 | Patch available | GHSA-78vv-qj73-h9m5 |
- Apache POI VendorApache Affected before 3.15 Fixed in 3.15 Patch available CNA
- org.apache.poi:poi (Maven) Vendor— Affected before 3.15 Fixed in 3.15 Patch available GHSA-78vv-qj73-h9m5
Remediation
- Fix · CNA Apache POI (Apache Software Foundation) Fixed in 3.15
- Fix · GHSA-78vv-qj73-h9m5 org.apache.poi:poi (Maven) Fixed in 3.15 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-5644
- 2026-10-03 Alias added: GHSA-78vv-qj73-h9m5
References
More Apache Poi vulnerabilities
- TI-2017-09351 Infinite loop in Apache POI CVSS 3.1HIGH 7.5
- TI-2014-02855 The OPC SAX setup in Apache POI before 3.10.1 allows remote attackers to read arbitrary… CVSS 2.0MEDIUM 4.3
- TI-2025-22816 Improper input validation in Apache POI CVSS 3.1MEDIUM 5.3
- TI-2012-00206 The UnhandledDataStructure function in hwpf/model/UnhandledDataStructure.java in Apache… CVSS 2.0MEDIUM 5.0
- TI-2016-04320 The XLSX2CSV example in Apache POI before 3.14 allows remote attackers to read arbitrary… CVSS 3.0MEDIUM 5.5
- TI-2014-07749 HSLFSlideShow in Apache POI before 3.11 allows remote attackers to cause a denial of… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2017-5644 · CVE Program
- CVE-2017-5644 · NVD
- FIRST EPSS
- GHSA-78vv-qj73-h9m5 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-5644 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences