Improper input validation in Apache POI
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 11 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.
Summary
Improper Input Validation vulnerability in Apache POI. The issue affects the parsing of OOXML format files like xlsx, docx and pptx. These file formats are basically zip files and it is possible for malicious users to add zip entries with duplicate names (including the path) in the zip. In this case, products reading the affected file could read different data because 1 of the zip entries with the duplicate name is selected over another but different products may choose a different zip entry. This issue affects Apache POI poi-ooxml before 5.4.0. poi-ooxml 5.4.0 has a check that throws an exception if zip entries with duplicate file names are found in the input file. Users are recommended to upgrade to version poi-ooxml 5.4.0, which fixes the issue. Please read https://poi.apache.org/security.html for recommendations about how to use the POI libraries securely.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache POI | before 5.4.0 | 5.4.0 | Patch available | CNA |
| — | org.apache.poi:poi-ooxml (Maven) | before 5.4.0 | 5.4.0 | Patch available | GHSA-gmg8-593g-7mv3 |
- Apache POI VendorApache Affected before 5.4.0 Fixed in 5.4.0 Patch available CNA
- org.apache.poi:poi-ooxml (Maven) Vendor— Affected before 5.4.0 Fixed in 5.4.0 Patch available GHSA-gmg8-593g-7mv3
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:poi:*:*:*:*:*:*:*:* | before 5.4.0 | Vulnerable | Apache |
| cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:linux:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:windows:*:* | not specified by NVD | Vulnerable | NetApp |
- cpe:2.3:a:apache:poi:*:*:*:*:*:*:*:* Versions before 5.4.0 Vulnerable ·Apache
- cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:linux:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:windows:*:* Versions not specified by NVD Vulnerable ·NetApp
Remediation
- Fix · CNA Apache POI (Apache Software Foundation) Fixed in 5.4.0
- Fix · GHSA-gmg8-593g-7mv3 org.apache.poi:poi-ooxml (Maven) Fixed in 5.4.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Logging Subsystem for Red Hat OpenShift | Affected | No fix yet: Fix deferred |
| Red Hat Fuse 7 | Affected | No fix yet: Fix deferred |
| Red Hat Integration Camel K 1 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform 8 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform Expansion Pack | Affected | No fix yet: Fix deferred |
| Red Hat Process Automation 7 | Affected | No fix yet: Fix deferred |
| Red Hat build of Apicurio Registry 3 | Affected | No fix yet: Fix deferred |
| Red Hat build of OptaPlanner 8 | Affected | No fix yet: Fix deferred |
| streams for Apache Kafka | Affected | No fix yet: Fix deferred |
| streams for Apache Kafka 2 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-31672
- 2026-10-03 Alias added: GHSA-gmg8-593g-7mv3
References
Advisory 4
More Apache Poi vulnerabilities
- TI-2017-09351 Infinite loop in Apache POI CVSS 3.1HIGH 7.5
- TI-2014-02855 The OPC SAX setup in Apache POI before 3.10.1 allows remote attackers to read arbitrary… CVSS 2.0MEDIUM 4.3
- TI-2012-00206 The UnhandledDataStructure function in hwpf/model/UnhandledDataStructure.java in Apache… CVSS 2.0MEDIUM 5.0
- TI-2017-03644 Apache POI in versions prior to release 3.15 allows remote attackers to cause a denial of… CVSS 3.0MEDIUM 5.5
- TI-2016-04320 The XLSX2CSV example in Apache POI before 3.14 allows remote attackers to read arbitrary… CVSS 3.0MEDIUM 5.5
- TI-2014-07749 HSLFSlideShow in Apache POI before 3.11 allows remote attackers to cause a denial of… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2025-31672 · CVE Program
- CVE-2025-31672 · NVD
- FIRST EPSS
- GHSA-gmg8-593g-7mv3 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-31672 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences