An incorrect implementation of "XEP-0280: Message Carbons" in multiple XMPP clients…
Priority LOW 28CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-346.
Summary
An incorrect implementation of "XEP-0280: Message Carbons" in multiple XMPP clients allows a remote attacker to impersonate any user, including contacts, in the vulnerable application's display. This allows for various kinds of social engineering attacks. This CVE is for Converse.js (0.8.0 - 1.0.6, 2.0.0 - 2.0.4).
Why it matters now
EPSS 0.0094 61st percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed converse.js (npm): 1.0.7, 2.0.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | converse.js (npm) | before 1.0.7 | 1.0.7 | Patch available | GHSA-w973-2qcc-p78x |
| — | converse.js (npm) | 2.0.0 to before 2.0.5 | 2.0.5 | Patch available | GHSA-w973-2qcc-p78x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- converse.js (npm) Vendor— Affected before 1.0.7 Fixed in 1.0.7 Patch available GHSA-w973-2qcc-p78x
- converse.js (npm) Vendor— Affected 2.0.0 to before 2.0.5 Fixed in 2.0.5 Patch available GHSA-w973-2qcc-p78x
CPE configurations NVD · 28
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:conversejs:converse.js:0.8.0:*:*:*:*:*:*:* | 0.8.0 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.8.1:*:*:*:*:*:*:* | 0.8.1 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.8.2:*:*:*:*:*:*:* | 0.8.2 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.8.3:*:*:*:*:*:*:* | 0.8.3 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.8.4:*:*:*:*:*:*:* | 0.8.4 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.8.5:*:*:*:*:*:*:* | 0.8.5 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.8.6:*:*:*:*:*:*:* | 0.8.6 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.9.0:*:*:*:*:*:*:* | 0.9.0 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.9.1:*:*:*:*:*:*:* | 0.9.1 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.9.2:*:*:*:*:*:*:* | 0.9.2 | Vulnerable | Conversejs |
- cpe:2.3:a:conversejs:converse.js:0.8.0:*:*:*:*:*:*:* Versions 0.8.0 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.8.1:*:*:*:*:*:*:* Versions 0.8.1 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.8.2:*:*:*:*:*:*:* Versions 0.8.2 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.8.3:*:*:*:*:*:*:* Versions 0.8.3 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.8.4:*:*:*:*:*:*:* Versions 0.8.4 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.8.5:*:*:*:*:*:*:* Versions 0.8.5 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.8.6:*:*:*:*:*:*:* Versions 0.8.6 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.9.0:*:*:*:*:*:*:* Versions 0.9.0 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.9.1:*:*:*:*:*:*:* Versions 0.9.1 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.9.2:*:*:*:*:*:*:* Versions 0.9.2 Vulnerable ·Conversejs
Show 18 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:conversejs:converse.js:0.9.3:*:*:*:*:*:*:* | 0.9.3 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.9.4:*:*:*:*:*:*:* | 0.9.4 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.9.5:*:*:*:*:*:*:* | 0.9.5 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.9.6:*:*:*:*:*:*:* | 0.9.6 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.10.0:*:*:*:*:*:*:* | 0.10.0 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:0.10.1:*:*:*:*:*:*:* | 0.10.1 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:1.0.1:*:*:*:*:*:*:* | 1.0.1 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:1.0.2:*:*:*:*:*:*:* | 1.0.2 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:1.0.3:*:*:*:*:*:*:* | 1.0.3 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:1.0.4:*:*:*:*:*:*:* | 1.0.4 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:1.0.5:*:*:*:*:*:*:* | 1.0.5 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:1.0.6:*:*:*:*:*:*:* | 1.0.6 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:2.0.3:*:*:*:*:*:*:* | 2.0.3 | Vulnerable | Conversejs |
| cpe:2.3:a:conversejs:converse.js:2.0.4:*:*:*:*:*:*:* | 2.0.4 | Vulnerable | Conversejs |
- cpe:2.3:a:conversejs:converse.js:0.9.3:*:*:*:*:*:*:* Versions 0.9.3 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.9.4:*:*:*:*:*:*:* Versions 0.9.4 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.9.5:*:*:*:*:*:*:* Versions 0.9.5 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.9.6:*:*:*:*:*:*:* Versions 0.9.6 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.10.0:*:*:*:*:*:*:* Versions 0.10.0 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:0.10.1:*:*:*:*:*:*:* Versions 0.10.1 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:1.0.2:*:*:*:*:*:*:* Versions 1.0.2 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:1.0.3:*:*:*:*:*:*:* Versions 1.0.3 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:1.0.4:*:*:*:*:*:*:* Versions 1.0.4 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:1.0.5:*:*:*:*:*:*:* Versions 1.0.5 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:1.0.6:*:*:*:*:*:*:* Versions 1.0.6 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·Conversejs
- cpe:2.3:a:conversejs:converse.js:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·Conversejs
Remediation
- Fix · GHSA-w973-2qcc-p78x converse.js (npm) Fixed in 1.0.7 Advisory →
- Fix · GHSA-w973-2qcc-p78x converse.js (npm) Fixed in 2.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-5858
- 2026-10-03 Alias added: GHSA-w973-2qcc-p78x
References
Exploit 3
More Conversejs Converse.js vulnerabilities
- TI-2018-04858 Converse.js and Inverse.js through 3.3 allow remote attackers to obtain sensitive… CVSS 3.0MEDIUM 5.3
Sources
- CVE-2017-5858 · CVE Program
- CVE-2017-5858 · NVD
- FIRST EPSS
- GHSA-w973-2qcc-p78x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences