Converse.js and Inverse.js through 3.3 allow remote attackers to obtain sensitive…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Converse.js and Inverse.js through 3.3 allow remote attackers to obtain sensitive information because it is too difficult to determine whether safe publication of private data was configured or even intended. For example, users might have an expectation that chatroom bookmarks are private, but the various interacting software components do not necessarily make that happen.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | jcbrand/converse.js (Packagist) | before 3.3.3 | 3.3.3 | Patch available | GHSA-mv4h-qm24-x4gh |
| — | converse.js (npm) | before 3.3.3 | 3.3.3 | Patch available | GHSA-mv4h-qm24-x4gh |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- jcbrand/converse.js (Packagist) Vendor— Affected before 3.3.3 Fixed in 3.3.3 Patch available GHSA-mv4h-qm24-x4gh
- converse.js (npm) Vendor— Affected before 3.3.3 Fixed in 3.3.3 Patch available GHSA-mv4h-qm24-x4gh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:conversejs:converse.js:*:*:*:*:*:*:*:* | up to 3.3 | Vulnerable | Conversejs |
- cpe:2.3:a:conversejs:converse.js:*:*:*:*:*:*:*:* Versions up to 3.3 Vulnerable ·Conversejs
Remediation
- Fix · GHSA-mv4h-qm24-x4gh jcbrand/converse.js (Packagist) Fixed in 3.3.3 Advisory →
- Fix · GHSA-mv4h-qm24-x4gh converse.js (npm) Fixed in 3.3.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6591
- 2026-10-03 Alias added: GHSA-mv4h-qm24-x4gh
References
More Conversejs Converse.js vulnerabilities
- TI-2017-03796 An incorrect implementation of "XEP-0280: Message Carbons" in multiple XMPP clients… CVSS 3.0MEDIUM 5.9
Sources
- CVE-2018-6591 · CVE Program
- CVE-2018-6591 · NVD
- FIRST EPSS
- GHSA-mv4h-qm24-x4gh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences