Improper input validation in Cisco Web Security Appliance
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
A vulnerability in the web interface of the Cisco Web Security Appliance (WSA) could allow an authenticated, remote attacker to perform command injection and elevate privileges to root. The attacker must authenticate with valid administrator credentials. Affected Products: Cisco AsyncOS Software 10.0 and later for WSA on both virtual and hardware appliances. More Information: CSCvd88862. Known Affected Releases: 10.1.0-204. Known Fixed Releases: 10.5.1-270 10.1.1-235.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Cisco Web Security Appliance | Cisco Web Security Appliance | — | No fix listed | CNA |
- Cisco Web Security Appliance Vendor— Affected Cisco Web Security Appliance Fixed in — No fix listed CNA
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cisco:web_security_appliance:10.0.0-233:*:*:*:*:*:*:* | 10.0.0-233 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:10.0_base:*:*:*:*:*:*:* | 10.0_base | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:10.1.0:*:*:*:*:*:*:* | 10.1.0 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:10.1.0-204:*:*:*:*:*:*:* | 10.1.0-204 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:10.1.1-230:*:*:*:*:*:*:* | 10.1.1-230 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:10.1.1-234:*:*:*:*:*:*:* | 10.1.1-234 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:10.5.0:*:*:*:*:*:*:* | 10.5.0 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:10.5.0-358:*:*:*:*:*:*:* | 10.5.0-358 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:11.0.0:*:*:*:*:*:*:* | 11.0.0 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:11.0.0-613:*:*:*:*:*:*:* | 11.0.0-613 | Vulnerable | Cisco |
- cpe:2.3:a:cisco:web_security_appliance:10.0.0-233:*:*:*:*:*:*:* Versions 10.0.0-233 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:10.0_base:*:*:*:*:*:*:* Versions 10.0_base Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:10.1.0:*:*:*:*:*:*:* Versions 10.1.0 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:10.1.0-204:*:*:*:*:*:*:* Versions 10.1.0-204 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:10.1.1-230:*:*:*:*:*:*:* Versions 10.1.1-230 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:10.1.1-234:*:*:*:*:*:*:* Versions 10.1.1-234 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:10.5.0:*:*:*:*:*:*:* Versions 10.5.0 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:10.5.0-358:*:*:*:*:*:*:* Versions 10.5.0-358 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:11.0.0:*:*:*:*:*:*:* Versions 11.0.0 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:11.0.0-613:*:*:*:*:*:*:* Versions 11.0.0-613 Vulnerable ·Cisco
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2017-6746
- 2026-10-03 Alias added: GHSA-gmcr-6x9x-76r5
References
More Cisco Web Security Appliance vulnerabilities
- TI-2023-06741 Buffer overflow in Cisco Secure Web Appliance CVSS 3.1CRITICAL 9.8
- TI-2018-00369 Uncontrolled resource consumption in Cisco AsyncOS Software for Cisco Web Security… CVSS 3.0HIGH 8.6
- TI-2019-01508 Cisco Web Security Appliance HTTPS Certificate Denial of Service Vulnerability CVSS 3.1HIGH 8.6
- TI-2018-00312 A vulnerability in traffic-monitoring functions in Cisco Web Security Appliance (WSA)… CVSS 3.0HIGH 7.5
- TI-2021-01086 Cisco Web Security Appliance Privilege Escalation Vulnerability CVSS 3.1HIGH 8.8
- TI-2019-11999 Cisco Web Security Appliance Unauthorized Device Reset Vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2017-6746 · CVE Program
- CVE-2017-6746 · NVD
- FIRST EPSS
- GHSA-gmcr-6x9x-76r5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences