Read the docs
TI-2017-05189 Aliases CVE-2017-7548GHSA-mmxj-523q-gvxr

Missing authorization in postgresql

Priority LOW 39CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-862.

Summary

PostgreSQL versions before 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers with no privileges on a large object to overwrite the entire contents of the object, resulting in a denial of service.

Why it matters now

EPSS 0.03517 89th percentileScored 2026-11-07
Fix Fixed postgresql (PostgreSQL): 9.4.13, 9.5.8, 9.6.4Red Hat: 2 advisories

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
PostgreSQLpostgresql9.4 to before 9.4.13; 9.5 to before 9.5.8; 9.6 to before 9.6.49.4.13, 9.5.8, 9.6.4Patch availableCNA
  • postgresql VendorPostgreSQL Affected 9.4 to before 9.4.13; 9.5 to before 9.5.8; 9.6 to before 9.6.4 Fixed in 9.4.13, 9.5.8, 9.6.4 Patch available CNA

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:*9.4 to before 9.4.13; 9.5 to before 9.5.8; 9.6 to before 9.6.4VulnerablePostgreSQL
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:* Versions 9.4 to before 9.4.13; 9.5 to before 9.5.8; 9.6 to before 9.6.4 Vulnerable ·PostgreSQL
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · CNA postgresql (PostgreSQL) Fixed in 9.4.13, 9.5.8, 9.6.4

Red Hat 2 advisories

  • RHSA-2017:2678 Released 2017-09-12 · Red Hat rating Moderate
    rh-postgresql94-postgresql security update
    • Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6) rh-postgresql94-postgresql-9.4.14-1.el6, rh-postgresql94-postgresql-contrib-9.4.14-1.el6, rh-postgresql94-postgresql-devel-9.4.14-1.el6 +9
    • Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-postgresql94-postgresql-9.4.14-1.el7, rh-postgresql94-postgresql-contrib-9.4.14-1.el7, rh-postgresql94-postgresql-devel-9.4.14-1.el7 +9
    • Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.7) rh-postgresql94-postgresql-9.4.14-1.el6, rh-postgresql94-postgresql-contrib-9.4.14-1.el6, rh-postgresql94-postgresql-devel-9.4.14-1.el6 +9
    • Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.3) rh-postgresql94-postgresql-9.4.14-1.el7, rh-postgresql94-postgresql-contrib-9.4.14-1.el7, rh-postgresql94-postgresql-devel-9.4.14-1.el7 +9
    • Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6) rh-postgresql94-postgresql-9.4.14-1.el6, rh-postgresql94-postgresql-contrib-9.4.14-1.el6, rh-postgresql94-postgresql-devel-9.4.14-1.el6 +9
    • Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-postgresql94-postgresql-9.4.14-1.el7, rh-postgresql94-postgresql-contrib-9.4.14-1.el7, rh-postgresql94-postgresql-devel-9.4.14-1.el7 +9
  • RHSA-2017:2677 Released 2017-09-12 · Red Hat rating Moderate
    rh-postgresql95-postgresql security update
    • Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6) rh-postgresql95-postgresql-9.5.9-1.el6, rh-postgresql95-postgresql-contrib-9.5.9-1.el6, rh-postgresql95-postgresql-devel-9.5.9-1.el6 +8
    • Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-postgresql95-postgresql-9.5.9-1.el7, rh-postgresql95-postgresql-contrib-9.5.9-1.el7, rh-postgresql95-postgresql-devel-9.5.9-1.el7 +8
    • Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.7) rh-postgresql95-postgresql-9.5.9-1.el6, rh-postgresql95-postgresql-contrib-9.5.9-1.el6, rh-postgresql95-postgresql-devel-9.5.9-1.el6 +8
    • Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.3) rh-postgresql95-postgresql-9.5.9-1.el7, rh-postgresql95-postgresql-contrib-9.5.9-1.el7, rh-postgresql95-postgresql-devel-9.5.9-1.el7 +8
    • Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6) rh-postgresql95-postgresql-9.5.9-1.el6, rh-postgresql95-postgresql-contrib-9.5.9-1.el6, rh-postgresql95-postgresql-devel-9.5.9-1.el6 +8
    • Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-postgresql95-postgresql-9.5.9-1.el7, rh-postgresql95-postgresql-contrib-9.5.9-1.el7, rh-postgresql95-postgresql-devel-9.5.9-1.el7 +8

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    postgresql — DSA-3935

    3 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2017-05187 Improper authentication in postgresqlPriority HIGH 77
    • TI-2017-05188 Insufficiently protected credentials in postgresqlPriority MEDIUM 47
  • Advisory ·

    postgresql — DSA-3936

    3 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2017-05187 Improper authentication in postgresqlPriority HIGH 77
    • TI-2017-05188 Insufficiently protected credentials in postgresqlPriority MEDIUM 47
Show 2 more groups
  • Advisory ·

    postgresql — RHSA-2017:2677

    3 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2017-05187 Improper authentication in postgresqlPriority HIGH 77
    • TI-2017-05188 Insufficiently protected credentials in postgresqlPriority MEDIUM 47
  • Advisory ·

    postgresql — RHSA-2017:2678

    3 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2017-05187 Improper authentication in postgresqlPriority HIGH 77
    • TI-2017-05188 Insufficiently protected credentials in postgresqlPriority MEDIUM 47

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6)Fixed RHSA-2017:2677, RHSA-2017:2678
Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7)Fixed RHSA-2017:2677, RHSA-2017:2678
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.7)Fixed RHSA-2017:2677, RHSA-2017:2678
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.3)Fixed RHSA-2017:2677, RHSA-2017:2678
Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6)Fixed RHSA-2017:2677, RHSA-2017:2678
Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7)Fixed RHSA-2017:2677, RHSA-2017:2678
Not affected: 5 products
  • CloudForms Management Engine 5
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Satellite 5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-7548
  2. 2026-10-03 Alias added: GHSA-mmxj-523q-gvxr

References

  • TI-2019-06651 In PostgreSQL 9.3 through 11.2, the "COPY TO/FROM PROGRAM" function allows superusers and… CVSS 3.0HIGH 7.2
  • TI-2017-05187 Improper authentication in postgresql CVSS 3.0CRITICAL 9.8
  • TI-2020-15711 SQL injection in postgresql CVSS 3.1HIGH 8.8
  • TI-2013-01675 Argument injection vulnerability in PostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9… CVSS 2.0MEDIUM 6.5
  • TI-2007-03176 The Database Link library (dblink) in PostgreSQL 8.1 implements functions via CREATE… CVSS 2.0HIGH 9.0
  • TI-2022-01423 SQL injection in postgresql CVSS 3.1HIGH 8.8
See all 202 →

Sources