Read the docs
TI-2017-05296 Aliases CVE-2017-7660GHSA-c82r-qg3w-q5mv

Improper authentication in Apache Solr

Priority MEDIUM 41CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-287.

Summary

Apache Solr uses a PKI based mechanism to secure inter-node communication when security is enabled. It is possible to create a specially crafted node name that does not exist as part of the cluster and point it to a malicious node. This can trick the nodes in cluster to believe that the malicious node is a member of the cluster. So, if Solr users have enabled BasicAuth authentication mechanism using the BasicAuthPlugin or if the user has implemented a custom Authentication plugin, which does not implement either "HttpClientInterceptorPlugin" or "HttpClientBuilderPlugin", his/her servers are vulnerable to this attack. Users who only use SSL without basic authentication or those who use Kerberos are not affected.

Why it matters now

EPSS 0.05632 92nd percentileScored 2026-11-07
Fix Partial org.apache.solr:solr-core (Maven): 5.5.5, 6.6.0Red Hat: 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Solr5.3 to 5.5.4; 6.0 to 6.5.1—No fix listedCNA
—org.apache.solr:solr-core (Maven)5.3.0 to before 5.5.55.5.5Patch availableGHSA-c82r-qg3w-q5mv
—org.apache.solr:solr-core (Maven)6.0.0 to before 6.6.06.6.0Patch availableGHSA-c82r-qg3w-q5mv
  • Apache Solr VendorApache Affected 5.3 to 5.5.4; 6.0 to 6.5.1 Fixed in — No fix listed CNA
  • org.apache.solr:solr-core (Maven) Vendor— Affected 5.3.0 to before 5.5.5 Fixed in 5.5.5 Patch available GHSA-c82r-qg3w-q5mv
  • org.apache.solr:solr-core (Maven) Vendor— Affected 6.0.0 to before 6.6.0 Fixed in 6.6.0 Patch available GHSA-c82r-qg3w-q5mv

CPE configurations NVD · 21

CPEVersionsRoleVendor
cpe:2.3:a:apache:solr:5.3.0:*:*:*:*:*:*:*5.3.0VulnerableApache
cpe:2.3:a:apache:solr:5.3.1:*:*:*:*:*:*:*5.3.1VulnerableApache
cpe:2.3:a:apache:solr:5.3.2:*:*:*:*:*:*:*5.3.2VulnerableApache
cpe:2.3:a:apache:solr:5.4.0:*:*:*:*:*:*:*5.4.0VulnerableApache
cpe:2.3:a:apache:solr:5.4.1:*:*:*:*:*:*:*5.4.1VulnerableApache
cpe:2.3:a:apache:solr:5.5.0:*:*:*:*:*:*:*5.5.0VulnerableApache
cpe:2.3:a:apache:solr:5.5.1:*:*:*:*:*:*:*5.5.1VulnerableApache
cpe:2.3:a:apache:solr:5.5.2:*:*:*:*:*:*:*5.5.2VulnerableApache
cpe:2.3:a:apache:solr:5.5.3:*:*:*:*:*:*:*5.5.3VulnerableApache
cpe:2.3:a:apache:solr:5.5.4:*:*:*:*:*:*:*5.5.4VulnerableApache
  • cpe:2.3:a:apache:solr:5.3.0:*:*:*:*:*:*:* Versions 5.3.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:5.3.1:*:*:*:*:*:*:* Versions 5.3.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:5.3.2:*:*:*:*:*:*:* Versions 5.3.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:5.4.0:*:*:*:*:*:*:* Versions 5.4.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:5.4.1:*:*:*:*:*:*:* Versions 5.4.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:5.5.0:*:*:*:*:*:*:* Versions 5.5.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:5.5.1:*:*:*:*:*:*:* Versions 5.5.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:5.5.2:*:*:*:*:*:*:* Versions 5.5.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:5.5.3:*:*:*:*:*:*:* Versions 5.5.3 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:5.5.4:*:*:*:*:*:*:* Versions 5.5.4 Vulnerable ·Apache
Show 11 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:apache:solr:6.0.0:*:*:*:*:*:*:*6.0.0VulnerableApache
cpe:2.3:a:apache:solr:6.0.1:*:*:*:*:*:*:*6.0.1VulnerableApache
cpe:2.3:a:apache:solr:6.1.0:*:*:*:*:*:*:*6.1.0VulnerableApache
cpe:2.3:a:apache:solr:6.2.0:*:*:*:*:*:*:*6.2.0VulnerableApache
cpe:2.3:a:apache:solr:6.2.1:*:*:*:*:*:*:*6.2.1VulnerableApache
cpe:2.3:a:apache:solr:6.3.0:*:*:*:*:*:*:*6.3.0VulnerableApache
cpe:2.3:a:apache:solr:6.4.0:*:*:*:*:*:*:*6.4.0VulnerableApache
cpe:2.3:a:apache:solr:6.4.1:*:*:*:*:*:*:*6.4.1VulnerableApache
cpe:2.3:a:apache:solr:6.4.2:*:*:*:*:*:*:*6.4.2VulnerableApache
cpe:2.3:a:apache:solr:6.5.0:*:*:*:*:*:*:*6.5.0VulnerableApache
cpe:2.3:a:apache:solr:6.5.1:*:*:*:*:*:*:*6.5.1VulnerableApache
  • cpe:2.3:a:apache:solr:6.0.0:*:*:*:*:*:*:* Versions 6.0.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:6.0.1:*:*:*:*:*:*:* Versions 6.0.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:6.1.0:*:*:*:*:*:*:* Versions 6.1.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:6.2.0:*:*:*:*:*:*:* Versions 6.2.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:6.2.1:*:*:*:*:*:*:* Versions 6.2.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:6.3.0:*:*:*:*:*:*:* Versions 6.3.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:6.4.0:*:*:*:*:*:*:* Versions 6.4.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:6.4.1:*:*:*:*:*:*:* Versions 6.4.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:6.4.2:*:*:*:*:*:*:* Versions 6.4.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:6.5.0:*:*:*:*:*:*:* Versions 6.5.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:solr:6.5.1:*:*:*:*:*:*:* Versions 6.5.1 Vulnerable ·Apache

Remediation

  • Fix · GHSA-c82r-qg3w-q5mv org.apache.solr:solr-core (Maven) Fixed in 5.5.5 Advisory →
  • Fix · GHSA-c82r-qg3w-q5mv org.apache.solr:solr-core (Maven) Fixed in 6.6.0 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat JBoss Fuse Service Works 6AffectedNo fix planned: Will not fix
Not affected: 5 products
  • Red Hat JBoss Data Grid 6
  • Red Hat JBoss Data Virtualization 6
  • Red Hat JBoss Enterprise Application Platform 6
  • Red Hat JBoss Fuse 6
  • Red Hat JBoss Portal 6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-7660
  2. 2026-10-03 Alias added: GHSA-c82r-qg3w-q5mv

References

  • TI-2024-30303 Apache Solr: Authentication bypass possible using a fake URL Path ending CVSS 3.1CRITICAL 9.8
  • TI-2019-13101 Injection in Apache Solr KEVCVSS 3.1HIGH 7.5
  • TI-2019-00170 Code injection in Apache Solr KEVCVSS 3.1HIGH 7.2
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2021-09240 SSRF vulnerability with the Replication handler CVSS 3.1CRITICAL 9.8
  • TI-2017-09354 XML external entity injection in Apache Solr before 7.1 with Apache Lucene before 7.1 CVSS 3.1CRITICAL 9.8
See all 46 →

Sources