Read the docs
TI-2017-05308 Aliases CVE-2017-7672GHSA-9gp7-jvm2-r4mx

Improper input validation in Apache Struts

Priority LOW 39CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.

Why it matters now

EPSS 0.09835 95th percentileScored 2026-11-07
Fix Fixed org.apache.struts:struts2-core (Maven): 2.5.12

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Struts2.5 to 2.5.10.1—No fix listedCNA
—org.apache.struts:struts2-core (Maven)2.5.0 to before 2.5.122.5.12Patch availableGHSA-9gp7-jvm2-r4mx
  • Apache Struts VendorApache Affected 2.5 to 2.5.10.1 Fixed in — No fix listed CNA
  • org.apache.struts:struts2-core (Maven) Vendor— Affected 2.5.0 to before 2.5.12 Fixed in 2.5.12 Patch available GHSA-9gp7-jvm2-r4mx

CPE configurations NVD · 7

CPEVersionsRoleVendor
cpe:2.3:a:apache:struts:2.5:*:*:*:*:*:*:*2.5VulnerableApache
cpe:2.3:a:apache:struts:2.5.1:*:*:*:*:*:*:*2.5.1VulnerableApache
cpe:2.3:a:apache:struts:2.5.2:*:*:*:*:*:*:*2.5.2VulnerableApache
cpe:2.3:a:apache:struts:2.5.5:*:*:*:*:*:*:*2.5.5VulnerableApache
cpe:2.3:a:apache:struts:2.5.8:*:*:*:*:*:*:*2.5.8VulnerableApache
cpe:2.3:a:apache:struts:2.5.10:*:*:*:*:*:*:*2.5.10VulnerableApache
cpe:2.3:a:apache:struts:2.5.10.1:*:*:*:*:*:*:*2.5.10.1VulnerableApache
  • cpe:2.3:a:apache:struts:2.5:*:*:*:*:*:*:* Versions 2.5 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.5.2:*:*:*:*:*:*:* Versions 2.5.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.5.5:*:*:*:*:*:*:* Versions 2.5.5 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.5.8:*:*:*:*:*:*:* Versions 2.5.8 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.5.10:*:*:*:*:*:*:* Versions 2.5.10 Vulnerable ·Apache
  • cpe:2.3:a:apache:struts:2.5.10.1:*:*:*:*:*:*:* Versions 2.5.10.1 Vulnerable ·Apache

Remediation

  • Fix · GHSA-9gp7-jvm2-r4mx org.apache.struts:struts2-core (Maven) Fixed in 2.5.12 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

Not affected: 3 products
  • Red Hat Enterprise Linux 5
  • Red Hat JBoss Enterprise Web Server 2
  • Red Hat Satellite 5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-7672
  2. 2026-10-03 Alias added: GHSA-9gp7-jvm2-r4mx

References

  • TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
  • TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
See all 98 →

Sources