Insufficiently protected credentials in Elastic X-Pack Reporting
Priority LOW 25CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure, Privilege escalation
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522 and CWE-269.
Summary
The Reporting feature in X-Pack in versions prior to 5.5.2 and standalone Reporting plugin versions versions prior to 2.4.6 had an impersonation vulnerability. A user with the reporting_user role could execute a report with the permissions of another reporting user, possibly gaining access to sensitive data.
Why it matters now
EPSS 0.00695 53rd percentileScored 2026-11-07
Fix Fixed org.elasticsearch.plugin:x-pack (Maven): 5.5.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Elastic X-Pack Reporting | Before 5.5.2 and 2.4.6 | — | No fix listed | CNA |
| — | org.elasticsearch.plugin:x-pack (Maven) | before 5.5.2 | 5.5.2 | Patch available | GHSA-m728-qvxh-xfjq |
- Elastic X-Pack Reporting VendorElastic Affected Before 5.5.2 and 2.4.6 Fixed in — No fix listed CNA
- org.elasticsearch.plugin:x-pack (Maven) Vendor— Affected before 5.5.2 Fixed in 5.5.2 Patch available GHSA-m728-qvxh-xfjq
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:elasticsearch:x-pack:*:*:*:*:*:*:*:* | up to 5.5.1 | Vulnerable | Elasticsearch |
| cpe:2.3:a:elasticsearch:x-pack_reporting:*:*:*:*:*:*:*:* | up to 2.4.5 | Vulnerable | Elasticsearch |
- cpe:2.3:a:elasticsearch:x-pack:*:*:*:*:*:*:*:* Versions up to 5.5.1 Vulnerable ·Elasticsearch
- cpe:2.3:a:elasticsearch:x-pack_reporting:*:*:*:*:*:*:*:* Versions up to 2.4.5 Vulnerable ·Elasticsearch
Remediation
- Fix · GHSA-m728-qvxh-xfjq org.elasticsearch.plugin:x-pack (Maven) Fixed in 5.5.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-8446
- 2026-10-03 Alias added: GHSA-m728-qvxh-xfjq
References
More Elastic vulnerabilities
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2018-12328 Kibana versions before 6.4.3 and 5.6.13 contain an arbitrary file inclusion flaw in the… CVSS 3.0CRITICAL 9.8
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
Sources
- CVE-2017-8446 · CVE Program
- CVE-2017-8446 · NVD
- FIRST EPSS
- GHSA-m728-qvxh-xfjq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences