Read the docs
TI-2017-06741 Aliases CVE-2017-9303GHSA-rc8x-jrrc-frfv

Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a…

Priority LOW 29CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.

Why it matters now

EPSS 0.00959 61st percentileScored 2026-11-07
Fix Fixed laravel/laravel (Packagist): 5.4.22illuminate/auth (Packagist): 5.4.22+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—laravel/laravel (Packagist)5.4.0 to before 5.4.225.4.22Patch availableGHSA-rc8x-jrrc-frfv
—illuminate/auth (Packagist)5.3.0 – 5.3.31—No fix listedGHSA-rc8x-jrrc-frfv
—illuminate/auth (Packagist)5.4.0 to before 5.4.225.4.22Patch availableGHSA-rc8x-jrrc-frfv
—laravel/framework (Packagist)5.3.0 – 5.3.31—No fix listedGHSA-rc8x-jrrc-frfv
—laravel/framework (Packagist)5.4.0 to before 5.4.225.4.22Patch availableGHSA-rc8x-jrrc-frfv
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • laravel/laravel (Packagist) Vendor— Affected 5.4.0 to before 5.4.22 Fixed in 5.4.22 Patch available GHSA-rc8x-jrrc-frfv
  • illuminate/auth (Packagist) Vendor— Affected 5.3.0 – 5.3.31 Fixed in — No fix listed GHSA-rc8x-jrrc-frfv
  • illuminate/auth (Packagist) Vendor— Affected 5.4.0 to before 5.4.22 Fixed in 5.4.22 Patch available GHSA-rc8x-jrrc-frfv
  • laravel/framework (Packagist) Vendor— Affected 5.3.0 – 5.3.31 Fixed in — No fix listed GHSA-rc8x-jrrc-frfv
  • laravel/framework (Packagist) Vendor— Affected 5.4.0 to before 5.4.22 Fixed in 5.4.22 Patch available GHSA-rc8x-jrrc-frfv

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:laravel:laravel:5.4.0:*:*:*:*:*:*:*5.4.0VulnerableLaravel
  • cpe:2.3:a:laravel:laravel:5.4.0:*:*:*:*:*:*:* Versions 5.4.0 Vulnerable ·Laravel

Remediation

  • Fix · GHSA-rc8x-jrrc-frfv laravel/laravel (Packagist) Fixed in 5.4.22 Advisory →
  • Fix · GHSA-rc8x-jrrc-frfv illuminate/auth (Packagist) Fixed in 5.4.22 Advisory →
  • Fix · GHSA-rc8x-jrrc-frfv laravel/framework (Packagist) Fixed in 5.4.22 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-9303
  2. 2026-10-03 Alias added: GHSA-rc8x-jrrc-frfv

References

  • TI-2018-10827 In Laravel Framework through 5.5.40 and 5.6.x through 5.6.29, remote code execution might… KEVCVSS 3.1HIGH 8.1
  • TI-2021-09454 A deserialization vulnerability in the destruct() function of Laravel v8.5.9 allows… CVSS 3.1CRITICAL 9.8
  • TI-2022-02662 laravel deserialization CVSS 3.1CRITICAL 9.8
  • TI-2017-12436 In Laravel framework through 5.5.21, remote attackers can obtain sensitive information… CVSS 3.0HIGH 7.5
  • TI-2022-02676 Laravel deserialization CVSS 3.1HIGH 8.8
  • TI-2021-04364 Query Binding Exploitation in Laravel CVSS 3.1HIGH 7.2
See all 9 →

Sources