Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the…
Priority LOW 36CWE-404Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-404.
Summary
Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.
Why it matters now
EPSS 0.01436 73rd percentileScored 2026-11-07
Fix Fixed Packetbeat (Elastic): 5.6.4github.com/elastic/beats (Go): 5.6.4, 6.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Packetbeat | before 5.6.4 | 5.6.4 | Patch available | CNA |
| — | github.com/elastic/beats (Go) | before 5.6.4 | 5.6.4 | Patch available | GHSA-9q3g-m353-cp4p |
| — | github.com/elastic/beats (Go) | 6.0.0-alpha1 to before 6.0.0 | 6.0.0 | Patch available | GHSA-9q3g-m353-cp4p |
- Packetbeat VendorElastic Affected before 5.6.4 Fixed in 5.6.4 Patch available CNA
- github.com/elastic/beats (Go) Vendor— Affected before 5.6.4 Fixed in 5.6.4 Patch available GHSA-9q3g-m353-cp4p
- github.com/elastic/beats (Go) Vendor— Affected 6.0.0-alpha1 to before 6.0.0 Fixed in 6.0.0 Patch available GHSA-9q3g-m353-cp4p
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:elasticsearch:packetbeat:*:*:*:*:*:*:*:* | before 5.6.4 | Vulnerable | Elasticsearch |
- cpe:2.3:a:elasticsearch:packetbeat:*:*:*:*:*:*:*:* Versions before 5.6.4 Vulnerable ·Elasticsearch
Remediation
- Fix · CNA Packetbeat (Elastic) Fixed in 5.6.4
- Fix · GHSA-9q3g-m353-cp4p github.com/elastic/beats (Go) Fixed in 5.6.4 Advisory →
- Fix · GHSA-9q3g-m353-cp4p github.com/elastic/beats (Go) Fixed in 6.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-11480
- 2026-10-03 Alias added: GHSA-9q3g-m353-cp4p
References
Advisory 2
More Elastic vulnerabilities
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2018-12328 Kibana versions before 6.4.3 and 5.6.13 contain an arbitrary file inclusion flaw in the… CVSS 3.0CRITICAL 9.8
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
Sources
- CVE-2017-11480 · CVE Program
- CVE-2017-11480 · NVD
- FIRST EPSS
- GHSA-9q3g-m353-cp4p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences