Incorrect authorization in Red Hat libpam4j
Priority LOW 32CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-863.
Summary
It was found that libpam4j up to and including 1.8 did not properly validate user accounts when authenticating. A user with a valid password for a disabled account would be able to bypass security restrictions and possibly access sensitive information.
Why it matters now
EPSS 0.01511 74th percentileScored 2026-11-07
Fix Fixed org.kohsuke:libpam4j (Maven): 1.10Red Hat: 3 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | libpam4j | up to and including 1.8 | — | No fix listed | CNA |
| — | org.kohsuke:libpam4j (Maven) | before 1.10 | 1.10 | Patch available | GHSA-x9rg-q5fx-fx66 |
- libpam4j VendorRed Hat Affected up to and including 1.8 Fixed in — No fix listed CNA
- org.kohsuke:libpam4j (Maven) Vendor— Affected before 1.10 Fixed in 1.10 Patch available GHSA-x9rg-q5fx-fx66
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libpam4j_project:libpam4j:*:*:*:*:*:*:*:* | up to 1.8 | Vulnerable | Libpam4j Project |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
- cpe:2.3:a:libpam4j_project:libpam4j:*:*:*:*:*:*:*:* Versions up to 1.8 Vulnerable ·Libpam4j Project
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-x9rg-q5fx-fx66 org.kohsuke:libpam4j (Maven) Fixed in 1.10 Advisory →
Red Hat 3 advisories
- RHSA-2017:2905 Released 2017-10-17 · Red Hat rating Moderaterh-sso7-keycloak security update
- Red Hat Single Sign-On 7.1 for RHEL 7 Server rh-sso7-keycloak-2.5.14-1.Final_redhat_1.1.jbcs.el7, rh-sso7-keycloak-server-2.5.14-1.Final_redhat_1.1.jbcs.el7
- RHSA-2017:2904 Released 2017-10-17 · Red Hat rating Moderaterh-sso7-keycloak security update
- Red Hat Single Sign-On 7.1 for RHEL 6 Server rh-sso7-keycloak-2.5.14-1.Final_redhat_1.1.jbcs.el6, rh-sso7-keycloak-server-2.5.14-1.Final_redhat_1.1.jbcs.el6
- RHSA-2017:2906 Released 2017-10-17 · Red Hat rating ModerateRed Hat Single Sign-On security update
- Red Hat Single Sign-On 7.1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Single Sign-On 7.1 | Fixed | RHSA-2017:2906 |
| Red Hat Single Sign-On 7.1 for RHEL 6 Server | Fixed | RHSA-2017:2904 |
| Red Hat Single Sign-On 7.1 for RHEL 7 Server | Fixed | RHSA-2017:2905 |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-12197
- 2026-10-03 Alias added: GHSA-x9rg-q5fx-fx66
References
Advisory 7
More Red Hat Enterprise Linux vulnerabilities
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2018-10530 Code injection in [UNKNOWN] RichFaces KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2025-23530 Sudo before 1.9.17p1 allows local users to obtain root access because /etc/nsswitch.conf… KEVCVSS 3.1CRITICAL 9.3
- TI-2021-17490 mod_proxy SSRF KEVCVSS 3.1CRITICAL 9.0
Sources
- CVE-2017-12197 · CVE Program
- CVE-2017-12197 · NVD
- FIRST EPSS
- GHSA-x9rg-q5fx-fx66 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-12197 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences