Lack of content verification in Docker-CE (Also known as Moby) versions 1.12.6-0, 1.10.3…
Priority LOW 34CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-770.
Summary
Lack of content verification in Docker-CE (Also known as Moby) versions 1.12.6-0, 1.10.3, 17.03.0, 17.03.1, 17.03.2, 17.06.0, 17.06.1, 17.06.2, 17.09.0, and earlier allows a remote attacker to cause a Denial of Service via a crafted image layer payload, aka gzip bombing.
Why it matters now
EPSS 0.0245 84th percentileScored 2026-11-07
Fix Partial github.com/vbatts/tar-split (Go): 0.10.2Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/vbatts/tar-split (Go) | before 0.10.2 | 0.10.2 | Patch available | GHSA-hqwh-8xv9-42hw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/vbatts/tar-split (Go) Vendor— Affected before 0.10.2 Fixed in 0.10.2 Patch available GHSA-hqwh-8xv9-42hw
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:docker:docker:*:*:*:*:community:*:*:* | up to 1.10.3 | Vulnerable | Docker |
| cpe:2.3:a:docker:docker:1.12.6-0:*:*:*:community:*:*:* | 1.12.6-0 | Vulnerable | Docker |
| cpe:2.3:a:docker:docker:17.03.0:*:*:*:community:*:*:* | 17.03.0 | Vulnerable | Docker |
| cpe:2.3:a:docker:docker:17.03.1:*:*:*:community:*:*:* | 17.03.1 | Vulnerable | Docker |
| cpe:2.3:a:docker:docker:17.03.2:*:*:*:community:*:*:* | 17.03.2 | Vulnerable | Docker |
| cpe:2.3:a:docker:docker:17.06.0:*:*:*:community:*:*:* | 17.06.0 | Vulnerable | Docker |
| cpe:2.3:a:docker:docker:17.06.1:*:*:*:community:*:*:* | 17.06.1 | Vulnerable | Docker |
| cpe:2.3:a:docker:docker:17.06.2:*:*:*:community:*:*:* | 17.06.2 | Vulnerable | Docker |
| cpe:2.3:a:docker:docker:17.09.0:*:*:*:community:*:*:* | 17.09.0 | Vulnerable | Docker |
- cpe:2.3:a:docker:docker:*:*:*:*:community:*:*:* Versions up to 1.10.3 Vulnerable ·Docker
- cpe:2.3:a:docker:docker:1.12.6-0:*:*:*:community:*:*:* Versions 1.12.6-0 Vulnerable ·Docker
- cpe:2.3:a:docker:docker:17.03.0:*:*:*:community:*:*:* Versions 17.03.0 Vulnerable ·Docker
- cpe:2.3:a:docker:docker:17.03.1:*:*:*:community:*:*:* Versions 17.03.1 Vulnerable ·Docker
- cpe:2.3:a:docker:docker:17.03.2:*:*:*:community:*:*:* Versions 17.03.2 Vulnerable ·Docker
- cpe:2.3:a:docker:docker:17.06.0:*:*:*:community:*:*:* Versions 17.06.0 Vulnerable ·Docker
- cpe:2.3:a:docker:docker:17.06.1:*:*:*:community:*:*:* Versions 17.06.1 Vulnerable ·Docker
- cpe:2.3:a:docker:docker:17.06.2:*:*:*:community:*:*:* Versions 17.06.2 Vulnerable ·Docker
- cpe:2.3:a:docker:docker:17.09.0:*:*:*:community:*:*:* Versions 17.09.0 Vulnerable ·Docker
Remediation
- Fix · GHSA-hqwh-8xv9-42hw github.com/vbatts/tar-split (Go) Fixed in 0.10.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-14992
- 2026-10-03 Alias added: GHSA-hqwh-8xv9-42hw
References
Advisory 2
More Docker vulnerabilities
- TI-2019-11833 Docker Desktop Community Edition before 2.1.0.1 allows local users to gain privileges by… KEVCVSS 3.1HIGH 7.8
- TI-2019-04061 runc through 1.0-rc6, as used in Docker before 18.09.2 and other products, allows… CVSS 3.1HIGH 8.6
- TI-2019-10626 In Docker 19.03.x before 19.03.1 linked against the GNU C Library (aka glibc), code… CVSS 3.1CRITICAL 9.8
- TI-2014-07591 Docker 1.3.2 allows remote attackers to execute arbitrary code with root privileges via a… CVSS 2.0HIGH 10.0
- TI-2014-00046 Improper input validation in docker.io CVSS 3.1CRITICAL 9.8
- TI-2014-07590 Path traversal vulnerability in Docker before 1.3.3 allows remote attackers to write to… CVSS 3.1HIGH 8.6
Sources
- CVE-2017-14992 · CVE Program
- CVE-2017-14992 · NVD
- FIRST EPSS
- GHSA-hqwh-8xv9-42hw · GitHub Advisory Database · CC BY 4.0
- CVE-2017-14992 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences