In Octopus before 3.17.7, an authenticated user who was explicitly granted the permission…
Priority LOW 30CWE-732Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
In Octopus before 3.17.7, an authenticated user who was explicitly granted the permission to invite new users (aka UserInvite) can invite users to teams with escalated privileges.
Why it matters now
EPSS 0.00727 54th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_deploy:*:*:*:*:*:*:*:* | up to 3.17.6 | Vulnerable | Octopus Deploy |
- cpe:2.3:a:octopus:octopus_deploy:*:*:*:*:*:*:*:* Versions up to 3.17.6 Vulnerable ·Octopus Deploy
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2017-15611
- 2026-10-03 Alias added: GHSA-p4m9-pfr4-hjwj
References
More Octopus Deploy vulnerabilities
- TI-2020-08583 In Octopus Deploy before 2020.1.5, for customers running on-premises Active Directory… CVSS 3.1HIGH 8.8
- TI-2018-04116 An issue was discovered in Octopus Deploy before 4.1.9. CVSS 3.0HIGH 8.8
- TI-2018-03438 In Octopus Deploy versions 3.2.11 - 4.1.5 (fixed in 4.1.6), an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2017-12930 In Octopus Deploy before 4.1.3, the machine update process doesn't check that the user… CVSS 3.0HIGH 8.8
- TI-2019-08703 In Octopus Deploy 2019.1.0 through 2019.3.1 and 2019.4.0 through 2019.4.5, an… CVSS 3.0HIGH 8.1
- TI-2020-15818 In Octopus Deploy 3.1.0 to 2020.4.0, certain scripts can reveal sensitive information to the user in the task logs. CVSS 3.1HIGH 7.5
Sources
- CVE-2017-15611 · CVE Program
- CVE-2017-15611 · NVD
- FIRST EPSS
- GHSA-p4m9-pfr4-hjwj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences