Deserialization of untrusted data in Apache Geode
Priority MEDIUM 50CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
In Apache Geode before v1.4.0, the TcpServer within the Geode locator opens a network port that deserializes data. If an unprivileged user gains access to the Geode locator, they may be able to cause remote code execution if certain classes are present on the classpath.
Why it matters now
EPSS 0.04781 91st percentileScored 2026-11-07
Fix Fixed org.apache.geode:geode-core (Maven): 1.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Geode | 1.0.0 to 1.3.0 | — | No fix listed | CNA |
| — | org.apache.geode:geode-core (Maven) | 1.0.0 to before 1.4.0 | 1.4.0 | Patch available | GHSA-w395-hpq9-7xwr |
- Apache Geode VendorApache Affected 1.0.0 to 1.3.0 Fixed in — No fix listed CNA
- org.apache.geode:geode-core (Maven) Vendor— Affected 1.0.0 to before 1.4.0 Fixed in 1.4.0 Patch available GHSA-w395-hpq9-7xwr
Remediation
- Fix · GHSA-w395-hpq9-7xwr org.apache.geode:geode-core (Maven) Fixed in 1.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-15692
- 2026-10-03 Alias added: GHSA-w395-hpq9-7xwr
References
More Apache Geode vulnerabilities
- TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2019-11833 Docker Desktop Community Edition before 2.1.0.1 allows local users to gain privileges by… KEVCVSS 3.1HIGH 7.8
- TI-2019-11096 Information disclosure in Red Hat jackson-databind CVSS 3.1CRITICAL 9.8
- TI-2014-00046 Improper input validation in docker.io CVSS 3.1CRITICAL 9.8
- TI-2022-17225 Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8. CVSS 3.1CRITICAL 9.8
- TI-2017-11469 Incorrect authorization in Apache Geode CVSS 3.0HIGH 8.8
Sources
- CVE-2017-15692 · CVE Program
- CVE-2017-15692 · NVD
- FIRST EPSS
- GHSA-w395-hpq9-7xwr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences