Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8.
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Geode | Apache Geode – 1.12.5 | — | No fix listed | CNA |
| — | org.apache.geode:geode-core (Maven) | before 1.12.16 | 1.12.16 | Patch available | GHSA-q4q3-r45f-7gwg |
| — | org.apache.geode:geode-core (Maven) | 1.13.0 to before 1.13.5 | 1.13.5 | Patch available | GHSA-q4q3-r45f-7gwg |
| — | org.apache.geode:geode-core (Maven) | 1.14.0 to before 1.14.1 | 1.14.1 | Patch available | GHSA-q4q3-r45f-7gwg |
- Apache Geode VendorApache Affected Apache Geode – 1.12.5 Fixed in — No fix listed CNA
- org.apache.geode:geode-core (Maven) Vendor— Affected before 1.12.16 Fixed in 1.12.16 Patch available GHSA-q4q3-r45f-7gwg
- org.apache.geode:geode-core (Maven) Vendor— Affected 1.13.0 to before 1.13.5 Fixed in 1.13.5 Patch available GHSA-q4q3-r45f-7gwg
- org.apache.geode:geode-core (Maven) Vendor— Affected 1.14.0 to before 1.14.1 Fixed in 1.14.1 Patch available GHSA-q4q3-r45f-7gwg
Remediation
- Fix · GHSA-q4q3-r45f-7gwg org.apache.geode:geode-core (Maven) Fixed in 1.12.16 Advisory →
- Fix · GHSA-q4q3-r45f-7gwg org.apache.geode:geode-core (Maven) Fixed in 1.13.5 Advisory →
- Fix · GHSA-q4q3-r45f-7gwg org.apache.geode:geode-core (Maven) Fixed in 1.14.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-37021
- 2026-10-03 Alias added: GHSA-q4q3-r45f-7gwg
References
More Apache Geode vulnerabilities
- TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2019-11833 Docker Desktop Community Edition before 2.1.0.1 allows local users to gain privileges by… KEVCVSS 3.1HIGH 7.8
- TI-2019-11096 Information disclosure in Red Hat jackson-databind CVSS 3.1CRITICAL 9.8
- TI-2014-00046 Improper input validation in docker.io CVSS 3.1CRITICAL 9.8
- TI-2017-11466 Deserialization of untrusted data in Apache Geode CVSS 3.0CRITICAL 9.8
- TI-2017-11469 Incorrect authorization in Apache Geode CVSS 3.0HIGH 8.8
Sources
- CVE-2022-37021 · CVE Program
- CVE-2022-37021 · NVD
- FIRST EPSS
- GHSA-q4q3-r45f-7gwg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences