Improper input validation in Apache Struts
Priority LOW 35CWE-20Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
In Apache Struts 2.5 to 2.5.14, the REST Plugin is using an outdated JSON-lib library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted JSON payload.
Why it matters now
EPSS 0.04889 92nd percentileScored 2026-11-07
Fix Fixed org.apache.struts:struts2-rest-plugin (Maven): 2.5.16
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Struts | 2.5 to 2.5.14 | — | No fix listed | CNA |
| — | org.apache.struts:struts2-rest-plugin (Maven) | 2.5.0 to before 2.5.16 | 2.5.16 | Patch available | GHSA-xcrm-qpp8-hcw4 |
- Apache Struts VendorApache Affected 2.5 to 2.5.14 Fixed in — No fix listed CNA
- org.apache.struts:struts2-rest-plugin (Maven) Vendor— Affected 2.5.0 to before 2.5.16 Fixed in 2.5.16 Patch available GHSA-xcrm-qpp8-hcw4
CPE configurations NVD · 20
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:* | 2.5 – 2.5.14 | Vulnerable | Apache |
| cpe:2.3:a:netapp:oncommand_balance:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:oracle:agile_plm_framework:9.3.6:*:*:*:*:*:*:* | 9.3.6 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:enterprise_manager_for_virtualization:13.2.2:*:*:*:*:*:*:* | 13.2.2 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:enterprise_manager_for_virtualization:13.2.3:*:*:*:*:*:*:* | 13.2.3 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:financial_services_hedge_management_and_ifrs_valuations:8.0.4:*:*:*:*:*:*:* | 8.0.4 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:financial_services_hedge_management_and_ifrs_valuations:8.0.5:*:*:*:*:*:*:* | 8.0.5 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:financial_services_market_risk_measurement_and_management:8.0.5:*:*:*:*:*:*:* | 8.0.5 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:global_lifecycle_management_opatchauto:*:*:*:*:*:*:*:* | all versions | Vulnerable | Oracle |
| cpe:2.3:a:oracle:jd_edwards_enterpriseone_tools:9.2:*:*:*:*:*:*:* | 9.2 | Vulnerable | Oracle |
- cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:* Versions 2.5 – 2.5.14 Vulnerable ·Apache
- cpe:2.3:a:netapp:oncommand_balance:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:oracle:agile_plm_framework:9.3.6:*:*:*:*:*:*:* Versions 9.3.6 Vulnerable ·Oracle
- cpe:2.3:a:oracle:enterprise_manager_for_virtualization:13.2.2:*:*:*:*:*:*:* Versions 13.2.2 Vulnerable ·Oracle
- cpe:2.3:a:oracle:enterprise_manager_for_virtualization:13.2.3:*:*:*:*:*:*:* Versions 13.2.3 Vulnerable ·Oracle
- cpe:2.3:a:oracle:financial_services_hedge_management_and_ifrs_valuations:8.0.4:*:*:*:*:*:*:* Versions 8.0.4 Vulnerable ·Oracle
- cpe:2.3:a:oracle:financial_services_hedge_management_and_ifrs_valuations:8.0.5:*:*:*:*:*:*:* Versions 8.0.5 Vulnerable ·Oracle
- cpe:2.3:a:oracle:financial_services_market_risk_measurement_and_management:8.0.5:*:*:*:*:*:*:* Versions 8.0.5 Vulnerable ·Oracle
- cpe:2.3:a:oracle:global_lifecycle_management_opatchauto:*:*:*:*:*:*:*:* Versions all versions Vulnerable ·Oracle
- cpe:2.3:a:oracle:jd_edwards_enterpriseone_tools:9.2:*:*:*:*:*:*:* Versions 9.2 Vulnerable ·Oracle
Show 10 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:oracle:retail_order_broker:5.2:*:*:*:*:*:*:* | 5.2 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:retail_xstore_point_of_service:6.5.11:*:*:*:*:*:*:* | 6.5.11 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:retail_xstore_point_of_service:7.0.6:*:*:*:*:*:*:* | 7.0.6 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:retail_xstore_point_of_service:7.1.6:*:*:*:*:*:*:* | 7.1.6 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:retail_xstore_point_of_service:15.0.1:*:*:*:*:*:*:* | 15.0.1 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:retail_xstore_point_of_service:16.0.2:*:*:*:*:*:*:* | 16.0.2 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:webcenter_portal:12.2.1.2.0:*:*:*:*:*:*:* | 12.2.1.2.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:webcenter_portal:12.2.1.3.0:*:*:*:*:*:*:* | 12.2.1.3.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:weblogic_server:12.2.1.2:*:*:*:*:*:*:* | 12.2.1.2 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:weblogic_server:12.2.1.3:*:*:*:*:*:*:* | 12.2.1.3 | Vulnerable | Oracle |
- cpe:2.3:a:oracle:retail_order_broker:5.2:*:*:*:*:*:*:* Versions 5.2 Vulnerable ·Oracle
- cpe:2.3:a:oracle:retail_xstore_point_of_service:6.5.11:*:*:*:*:*:*:* Versions 6.5.11 Vulnerable ·Oracle
- cpe:2.3:a:oracle:retail_xstore_point_of_service:7.0.6:*:*:*:*:*:*:* Versions 7.0.6 Vulnerable ·Oracle
- cpe:2.3:a:oracle:retail_xstore_point_of_service:7.1.6:*:*:*:*:*:*:* Versions 7.1.6 Vulnerable ·Oracle
- cpe:2.3:a:oracle:retail_xstore_point_of_service:15.0.1:*:*:*:*:*:*:* Versions 15.0.1 Vulnerable ·Oracle
- cpe:2.3:a:oracle:retail_xstore_point_of_service:16.0.2:*:*:*:*:*:*:* Versions 16.0.2 Vulnerable ·Oracle
- cpe:2.3:a:oracle:webcenter_portal:12.2.1.2.0:*:*:*:*:*:*:* Versions 12.2.1.2.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:webcenter_portal:12.2.1.3.0:*:*:*:*:*:*:* Versions 12.2.1.3.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:weblogic_server:12.2.1.2:*:*:*:*:*:*:* Versions 12.2.1.2 Vulnerable ·Oracle
- cpe:2.3:a:oracle:weblogic_server:12.2.1.3:*:*:*:*:*:*:* Versions 12.2.1.3 Vulnerable ·Oracle
Remediation
- Fix · GHSA-xcrm-qpp8-hcw4 org.apache.struts:struts2-rest-plugin (Maven) Fixed in 2.5.16 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat JBoss Fuse Service Works 6
Timeline
- 2026-10-02 Threatist record created from CVE-2017-15707
- 2026-10-03 Alias added: GHSA-xcrm-qpp8-hcw4
References
Patch 3
Advisory 3
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2017-15707 · CVE Program
- CVE-2017-15707 · NVD
- FIRST EPSS
- GHSA-xcrm-qpp8-hcw4 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-15707 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences