Cross-Site Scripting vulnerability in KeystoneJS before 4.0.0-beta.7 allows remote…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-Site Scripting vulnerability in KeystoneJS before 4.0.0-beta.7 allows remote authenticated administrators to inject arbitrary web script or HTML via the "content brief" or "content extended" field, a different vulnerability than CVE-2017-15878.
Why it matters now
EPSS 0.01215 68th percentileScored 2026-11-07
Fix Fixed keystone (npm): 4.0.0-beta7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | keystone (npm) | before 4.0.0-beta7 | 4.0.0-beta7 | Patch available | GHSA-7cv6-gvx3-m54m |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- keystone (npm) Vendor— Affected before 4.0.0-beta7 Fixed in 4.0.0-beta7 Patch available GHSA-7cv6-gvx3-m54m
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:keystonejs:keystone:*:*:*:*:*:node.js:*:* | up to 0.3.22 | Vulnerable | keystonejs |
| cpe:2.3:a:keystonejs:keystone:4.0.0:-:*:*:*:node.js:*:* | 4.0.0 | Vulnerable | keystonejs |
| cpe:2.3:a:keystonejs:keystone:4.0.0:beta1:*:*:*:node.js:*:* | 4.0.0 beta1 | Vulnerable | keystonejs |
| cpe:2.3:a:keystonejs:keystone:4.0.0:beta2:*:*:*:node.js:*:* | 4.0.0 beta2 | Vulnerable | keystonejs |
| cpe:2.3:a:keystonejs:keystone:4.0.0:beta3:*:*:*:node.js:*:* | 4.0.0 beta3 | Vulnerable | keystonejs |
| cpe:2.3:a:keystonejs:keystone:4.0.0:beta4:*:*:*:node.js:*:* | 4.0.0 beta4 | Vulnerable | keystonejs |
| cpe:2.3:a:keystonejs:keystone:4.0.0:beta5:*:*:*:node.js:*:* | 4.0.0 beta5 | Vulnerable | keystonejs |
- cpe:2.3:a:keystonejs:keystone:*:*:*:*:*:node.js:*:* Versions up to 0.3.22 Vulnerable ·keystonejs
- cpe:2.3:a:keystonejs:keystone:4.0.0:-:*:*:*:node.js:*:* Versions 4.0.0 Vulnerable ·keystonejs
- cpe:2.3:a:keystonejs:keystone:4.0.0:beta1:*:*:*:node.js:*:* Versions 4.0.0 beta1 Vulnerable ·keystonejs
- cpe:2.3:a:keystonejs:keystone:4.0.0:beta2:*:*:*:node.js:*:* Versions 4.0.0 beta2 Vulnerable ·keystonejs
- cpe:2.3:a:keystonejs:keystone:4.0.0:beta3:*:*:*:node.js:*:* Versions 4.0.0 beta3 Vulnerable ·keystonejs
- cpe:2.3:a:keystonejs:keystone:4.0.0:beta4:*:*:*:node.js:*:* Versions 4.0.0 beta4 Vulnerable ·keystonejs
- cpe:2.3:a:keystonejs:keystone:4.0.0:beta5:*:*:*:node.js:*:* Versions 4.0.0 beta5 Vulnerable ·keystonejs
Remediation
- Fix · GHSA-7cv6-gvx3-m54m keystone (npm) Fixed in 4.0.0-beta7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-15881
- 2026-10-03 Alias added: GHSA-7cv6-gvx3-m54m
References
Advisory 4
More keystonejs Keystone vulnerabilities
- TI-2022-18756 NODE_ENV in Keystone defaults to development with esbuild CVSS 3.1CRITICAL 9.8
- TI-2022-18698 @keystone-6/core vulnerable to field-level access-control bypass for multiselect field CVSS 3.1CRITICAL 9.8
- TI-2017-11626 CSV Injection (aka Excel Macro Injection or Formula Injection) exists in… CVSS 3.0HIGH 8.8
- TI-2022-11852 An arbitrary file upload vulnerability in the file upload module of Keystone v4.2.1… CVSS 3.1CRITICAL 9.8
- TI-2017-12181 KeystoneJS before 4.0.0-beta.7 allows application-wide CSRF bypass by removing the CSRF… CVSS 3.0HIGH 8.8
- TI-2015-07619 Credentials management flaw in HackerOne keystone node module CVSS 3.0HIGH 7.5
Sources
- CVE-2017-15881 · CVE Program
- CVE-2017-15881 · NVD
- FIRST EPSS
- GHSA-7cv6-gvx3-m54m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences