Cross-site scripting in HackerOne i18next node module
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
i18next is a language translation framework. Because of how the interpolation is implemented, making replacements from the dictionary one at a time, untrusted user input can use the name of one of the dictionary keys to inject script into the browser. This affects i18next <=1.10.2.
Why it matters now
EPSS 0.00849 58th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed i18next (npm): 1.10.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | i18next node module | up to 1.10.2 | — | No fix listed | CNA |
| — | i18next (npm) | before 1.10.3 | 1.10.3 | Patch available | GHSA-f89g-whpf-6q9m |
- i18next node module VendorHackerOne Affected up to 1.10.2 Fixed in — No fix listed CNA
- i18next (npm) Vendor— Affected before 1.10.3 Fixed in 1.10.3 Patch available GHSA-f89g-whpf-6q9m
Remediation
- Fix · GHSA-f89g-whpf-6q9m i18next (npm) Fixed in 1.10.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16008
- 2026-10-03 Alias added: GHSA-f89g-whpf-6q9m
References
More I18next vulnerabilities
- TI-2017-11737 Cross-site scripting in HackerOne i18next node module CVSS 3.0MEDIUM 6.1
Sources
- CVE-2017-16008 · CVE Program
- CVE-2017-16008 · NVD
- FIRST EPSS
- GHSA-f89g-whpf-6q9m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences