Read the docs
TI-2017-11737 Aliases CVE-2017-16010GHSA-cmh5-qc8w-xvcq

Cross-site scripting in HackerOne i18next node module

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

i18next is a language translation framework. When using the .init method, passing interpolation options without passing an escapeValue will default to undefined rather than the assumed true. This can result in a cross-site scripting vulnerability because user input is assumed to be escaped, but is not. This vulnerability affects i18next 2.0.0 and later.

Why it matters now

EPSS 0.00982 62nd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed i18next (npm): 3.4.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
HackerOnei18next node module>=2.0.0 <=3.4.3—No fix listedCNA
—i18next (npm)2.0.0 to before 3.4.43.4.4Patch availableGHSA-cmh5-qc8w-xvcq
  • i18next node module VendorHackerOne Affected >=2.0.0 <=3.4.3 Fixed in — No fix listed CNA
  • i18next (npm) Vendor— Affected 2.0.0 to before 3.4.4 Fixed in 3.4.4 Patch available GHSA-cmh5-qc8w-xvcq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:i18next:i18next:*:*:*:*:*:node.js:*:*2.0.0 – 3.4.3Vulnerablei18next
  • cpe:2.3:a:i18next:i18next:*:*:*:*:*:node.js:*:* Versions 2.0.0 – 3.4.3 Vulnerable ·i18next

Remediation

  • Fix · GHSA-cmh5-qc8w-xvcq i18next (npm) Fixed in 3.4.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-16010
  2. 2026-10-03 Alias added: GHSA-cmh5-qc8w-xvcq

References

  • TI-2017-11735 Cross-site scripting in HackerOne i18next node module CVSS 3.0MEDIUM 6.1

Sources