Cross-site scripting in HackerOne sanitize-html node module
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Sanitize-html is a library for scrubbing html input of malicious values. Versions 1.11.1 and below are vulnerable to cross site scripting (XSS) in certain scenarios: If allowed at least one nonTextTags, the result is a potential XSS vulnerability.
Why it matters now
EPSS 0.01336 71st percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed sanitize-html (npm): 1.11.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | sanitize-html node module | up to 1.11.1 | — | No fix listed | CNA |
| — | sanitize-html (npm) | before 1.11.4 | 1.11.4 | Patch available | GHSA-xc6g-ggrc-qq4r |
- sanitize-html node module VendorHackerOne Affected up to 1.11.1 Fixed in — No fix listed CNA
- sanitize-html (npm) Vendor— Affected before 1.11.4 Fixed in 1.11.4 Patch available GHSA-xc6g-ggrc-qq4r
Remediation
- Fix · GHSA-xc6g-ggrc-qq4r sanitize-html (npm) Fixed in 1.11.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16016
- 2026-10-03 Alias added: GHSA-xc6g-ggrc-qq4r
References
Advisory 2
More Punkave Sanitize-html vulnerabilities
- TI-2017-11742 Cross-site scripting in HackerOne sanitize-html node module CVSS 3.0MEDIUM 6.1
Sources
- CVE-2017-16016 · CVE Program
- CVE-2017-16016 · NVD
- FIRST EPSS
- GHSA-xc6g-ggrc-qq4r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences