Cross-site scripting in HackerOne sanitize-html node module
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
sanitize-html is a library for scrubbing html input for malicious values Versions 1.2.2 and below have a cross site scripting vulnerability.
Why it matters now
EPSS 0.01167 67th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed sanitize-html (npm): 1.2.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | sanitize-html node module | up to 1.2.2 | — | No fix listed | CNA |
| — | sanitize-html (npm) | before 1.2.3 | 1.2.3 | Patch available | GHSA-wg96-3933-j2w5 |
- sanitize-html node module VendorHackerOne Affected up to 1.2.2 Fixed in — No fix listed CNA
- sanitize-html (npm) Vendor— Affected before 1.2.3 Fixed in 1.2.3 Patch available GHSA-wg96-3933-j2w5
Remediation
- Fix · GHSA-wg96-3933-j2w5 sanitize-html (npm) Fixed in 1.2.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16017
- 2026-10-03 Alias added: GHSA-wg96-3933-j2w5
References
More Punkave Sanitize-html vulnerabilities
- TI-2017-11741 Cross-site scripting in HackerOne sanitize-html node module CVSS 3.0MEDIUM 6.1
Sources
- CVE-2017-16017 · CVE Program
- CVE-2017-16017 · NVD
- FIRST EPSS
- GHSA-wg96-3933-j2w5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences