Uncontrolled resource consumption in HackerOne nes node module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Denial of service, Security bypass
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400 and CWE-287.
Summary
Nes is a websocket extension library for hapi. Hapi is a webserver framework. Versions below and including 6.4.0 have a denial of service vulnerability via an invalid Cookie header. This is only present when websocket authentication is set to `cookie`. Submitting an invalid cookie on the websocket upgrade request will cause the node process to error out.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | nes node module | up to 6.4.0 | — | No fix listed | CNA |
| — | nes (npm) | before 6.4.1 | 6.4.1 | Patch available | GHSA-3pwh-5mmc-mwrx |
- nes node module VendorHackerOne Affected up to 6.4.0 Fixed in — No fix listed CNA
- nes (npm) Vendor— Affected before 6.4.1 Fixed in 6.4.1 Patch available GHSA-3pwh-5mmc-mwrx
Remediation
- Fix · GHSA-3pwh-5mmc-mwrx nes (npm) Fixed in 6.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16025
- 2026-10-03 Alias added: GHSA-3pwh-5mmc-mwrx
References
Advisory 4
Sources
- CVE-2017-16025 · CVE Program
- CVE-2017-16025 · NVD
- FIRST EPSS
- GHSA-3pwh-5mmc-mwrx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences