Read the docs
TI-2017-12752 Aliases CVE-2017-17458GHSA-6v56-cpg6-3rpx

In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause…

Priority MEDIUM 51CWE-78Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-78.

Summary

In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repository. Typical use of Mercurial prevents construction of such repositories, but they can be created programmatically.

Why it matters now

EPSS 0.06331 93rd percentileScored 2026-11-07
Fix Partial mercurial (PyPI): 4.4.1Red Hat: 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mercurial (PyPI)before 4.4.14.4.1Patch availableGHSA-6v56-cpg6-3rpx
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mercurial (PyPI) Vendor— Affected before 4.4.1 Fixed in 4.4.1 Patch available GHSA-6v56-cpg6-3rpx

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:mercurial:mercurial:*:*:*:*:*:*:*:*before 4.4.1VulnerableMercurial
cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*7.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
  • cpe:2.3:a:mercurial:mercurial:*:*:*:*:*:*:*:* Versions before 4.4.1 Vulnerable ·Mercurial
  • cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-6v56-cpg6-3rpx mercurial (PyPI) Fixed in 4.4.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux 7AffectedNo fix planned: Will not fix

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-17458
  2. 2026-10-03 Alias added: GHSA-6v56-cpg6-3rpx

References

Sources