The Net::LDAP (aka net-ldap) gem before 0.16.0 for Ruby has Missing SSL Certificate Validation.
Priority LOW 29CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 2 fixed, 2 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-295.
Summary
The Net::LDAP (aka net-ldap) gem before 0.16.0 for Ruby has Missing SSL Certificate Validation.
Why it matters now
EPSS 0.01348 71st percentileScored 2026-11-07
Fix Partial net-ldap (RubyGems): 0.16.0Red Hat: 1 advisoryRed Hat: 2 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | net-ldap (RubyGems) | before 0.16.0 | 0.16.0 | Patch available | GHSA-m7p8-9w66-9frm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- net-ldap (RubyGems) Vendor— Affected before 0.16.0 Fixed in 0.16.0 Patch available GHSA-m7p8-9w66-9frm
CPE configurations NVD · 22
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:net-ldap_project:net-ldap:0.0.5:*:*:*:*:ruby:*:* | 0.0.5 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.1.0:*:*:*:*:ruby:*:* | 0.1.0 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.1.1:*:*:*:*:ruby:*:* | 0.1.1 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.2:*:*:*:*:ruby:*:* | 0.2 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.2.1:*:*:*:*:ruby:*:* | 0.2.1 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.2.2:*:*:*:*:ruby:*:* | 0.2.2 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.3.0:*:*:*:*:ruby:*:* | 0.3.0 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.3.1:*:*:*:*:ruby:*:* | 0.3.1 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.5.1:*:*:*:*:ruby:*:* | 0.5.1 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.6.0:*:*:*:*:ruby:*:* | 0.6.0 | Vulnerable | Net-ldap Project |
- cpe:2.3:a:net-ldap_project:net-ldap:0.0.5:*:*:*:*:ruby:*:* Versions 0.0.5 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.1.0:*:*:*:*:ruby:*:* Versions 0.1.0 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.1.1:*:*:*:*:ruby:*:* Versions 0.1.1 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.2:*:*:*:*:ruby:*:* Versions 0.2 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.2.1:*:*:*:*:ruby:*:* Versions 0.2.1 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.2.2:*:*:*:*:ruby:*:* Versions 0.2.2 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.3.0:*:*:*:*:ruby:*:* Versions 0.3.0 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.3.1:*:*:*:*:ruby:*:* Versions 0.3.1 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.5.1:*:*:*:*:ruby:*:* Versions 0.5.1 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.6.0:*:*:*:*:ruby:*:* Versions 0.6.0 Vulnerable ·Net-ldap Project
Show 12 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:net-ldap_project:net-ldap:0.6.1:*:*:*:*:ruby:*:* | 0.6.1 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.7.0:*:*:*:*:ruby:*:* | 0.7.0 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.8.0:*:*:*:*:ruby:*:* | 0.8.0 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.9.0:*:*:*:*:ruby:*:* | 0.9.0 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.10.0:*:*:*:*:ruby:*:* | 0.10.0 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.10.1:*:*:*:*:ruby:*:* | 0.10.1 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.11:*:*:*:*:ruby:*:* | 0.11 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.12.0:*:*:*:*:ruby:*:* | 0.12.0 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.12.1:*:*:*:*:ruby:*:* | 0.12.1 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.13.0:*:*:*:*:ruby:*:* | 0.13.0 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.14.0:*:*:*:*:ruby:*:* | 0.14.0 | Vulnerable | Net-ldap Project |
| cpe:2.3:a:net-ldap_project:net-ldap:0.15.0:*:*:*:*:ruby:*:* | 0.15.0 | Vulnerable | Net-ldap Project |
- cpe:2.3:a:net-ldap_project:net-ldap:0.6.1:*:*:*:*:ruby:*:* Versions 0.6.1 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.7.0:*:*:*:*:ruby:*:* Versions 0.7.0 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.8.0:*:*:*:*:ruby:*:* Versions 0.8.0 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.9.0:*:*:*:*:ruby:*:* Versions 0.9.0 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.10.0:*:*:*:*:ruby:*:* Versions 0.10.0 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.10.1:*:*:*:*:ruby:*:* Versions 0.10.1 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.11:*:*:*:*:ruby:*:* Versions 0.11 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.12.0:*:*:*:*:ruby:*:* Versions 0.12.0 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.12.1:*:*:*:*:ruby:*:* Versions 0.12.1 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.13.0:*:*:*:*:ruby:*:* Versions 0.13.0 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.14.0:*:*:*:*:ruby:*:* Versions 0.14.0 Vulnerable ·Net-ldap Project
- cpe:2.3:a:net-ldap_project:net-ldap:0.15.0:*:*:*:*:ruby:*:* Versions 0.15.0 Vulnerable ·Net-ldap Project
Remediation
- Fix · GHSA-m7p8-9w66-9frm net-ldap (RubyGems) Fixed in 0.16.0 Advisory →
Red Hat 1 advisory
- RHSA-2020:1454 Released 2020-04-14 · Red Hat rating ImportantSatellite 6.7 release.
- Red Hat Satellite 6.7 ansible-runner-1.3.4-2.el7ar, ansiblerole-foreman_scap_client-0.0.3-1.el7sat, ansiblerole-insights-client-1.7.1-1.el7sat +47
- Red Hat Satellite Capsule 6.7 ansible-runner-1.3.4-2.el7ar, ansiblerole-foreman_scap_client-0.0.3-1.el7sat, ansiblerole-insights-client-1.7.1-1.el7sat +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 1.3 | Affected | No fix planned: Will not fix |
| Red Hat Subscription Asset Manager | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6.7 | Fixed | RHSA-2020:1454 |
| Red Hat Satellite Capsule 6.7 | Fixed | RHSA-2020:1454 |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-17718
- 2026-10-03 Alias added: GHSA-m7p8-9w66-9frm
References
More Net-ldap Project Net-ldap vulnerabilities
- TI-2014-00078 The Ruby net-ldap gem before 0.11 uses a weak salt when generating SSHA passwords. CVSS 3.1MEDIUM 5.5
Sources
- CVE-2017-17718 · CVE Program
- CVE-2017-17718 · NVD
- FIRST EPSS
- GHSA-m7p8-9w66-9frm · GitHub Advisory Database · CC BY 4.0
- CVE-2017-17718 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences