In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly…
Priority LOW 37Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly protected because POST (in addition to GET) parameters are stored in the session and become available in the environment of the callback phase.
Why it matters now
EPSS 0.02129 82nd percentileScored 2026-11-07
Fix Fixed omniauth (RubyGems): 1.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | omniauth (RubyGems) | before 1.3.2 | 1.3.2 | Patch available | GHSA-9pr6-grf4-x2fr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- omniauth (RubyGems) Vendor— Affected before 1.3.2 Fixed in 1.3.2 Patch available GHSA-9pr6-grf4-x2fr
Remediation
- Fix · GHSA-9pr6-grf4-x2fr omniauth (RubyGems) Fixed in 1.3.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-18076
- 2026-10-03 Alias added: GHSA-9pr6-grf4-x2fr
References
Patch 2
Sources
- CVE-2017-18076 · CVE Program
- CVE-2017-18076 · NVD
- FIRST EPSS
- GHSA-9pr6-grf4-x2fr · GitHub Advisory Database · CC BY 4.0
- CVE-2017-18076 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences