Read the docs

OmniAuth

Records9All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical5CVSS 9.0–10.0
CVSS high3CVSS 7.0–8.9

Exploited now

OmniAuth records in CISA KEV

No OmniAuth vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

9 records

Priority MEDIUM 47

OmniAuth OmnitAuth-SAML 1.9.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.02435 Published 2019-04-17 Fixed in 1.9.0, 1.10.0 CWE-287
Priority MEDIUM 41

The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user int…

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.01525 Published 2019-04-26 Partial fix · 2.0.0 CWE-352
Open these records in search →