Read the docs
TI-2017-13449 Aliases CVE-2017-18264GHSA-5868-g58j-vrj5

An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20…

Priority MEDIUM 47CWE-269Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Privilege escalation
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-269.

Summary

An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.

Why it matters now

EPSS 0.02818 86th percentileScored 2026-11-07
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 4.0.10.20, 4.7.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—phpmyadmin/phpmyadmin (Packagist)4.0 to before 4.0.10.204.0.10.20Patch availableGHSA-5868-g58j-vrj5
—phpmyadmin/phpmyadmin (Packagist)4.7.0-beta1 to before 4.7.04.7.0Patch availableGHSA-5868-g58j-vrj5
—phpmyadmin/phpmyadmin (Packagist)4.4.0 – 4.4.15.10—No fix listedGHSA-5868-g58j-vrj5
—phpmyadmin/phpmyadmin (Packagist)4.6.0 – 4.6.6—No fix listedGHSA-5868-g58j-vrj5
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.0 to before 4.0.10.20 Fixed in 4.0.10.20 Patch available GHSA-5868-g58j-vrj5
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.7.0-beta1 to before 4.7.0 Fixed in 4.7.0 Patch available GHSA-5868-g58j-vrj5
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.4.0 – 4.4.15.10 Fixed in — No fix listed GHSA-5868-g58j-vrj5
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.6.0 – 4.6.6 Fixed in — No fix listed GHSA-5868-g58j-vrj5

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*4.0.0 to before 4.0.10.20; 4.4.0 – 4.4.15.10; 4.6.0 – 4.6.6VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:4.7.0:beta1:*:*:*:*:*:*4.7.0 beta1VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:4.7.0:rc1:*:*:*:*:*:*4.7.0 rc1VulnerablephpMyAdmin
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
  • cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.0.10.20; 4.4.0 – 4.4.15.10; 4.6.0 – 4.6.6 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.7.0:beta1:*:*:*:*:*:* Versions 4.7.0 beta1 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:4.7.0:rc1:*:*:*:*:*:* Versions 4.7.0 rc1 Vulnerable ·phpMyAdmin
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-5868-g58j-vrj5 phpmyadmin/phpmyadmin (Packagist) Fixed in 4.0.10.20 Advisory →
  • Fix · GHSA-5868-g58j-vrj5 phpmyadmin/phpmyadmin (Packagist) Fixed in 4.7.0 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-18264
  2. 2026-10-03 Alias added: GHSA-5868-g58j-vrj5

References

Sources