An issue was discovered in Mattermost Server before 4.4.3 and 4.3.3.
Priority LOW 21CWE-732Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
An issue was discovered in Mattermost Server before 4.4.3 and 4.3.3. Attackers could reconfigure an OAuth app in some cases where Mattermost is an OAuth 2.0 service provider.
Why it matters now
EPSS 0.00569 47th percentileScored 2026-11-07
Fix Fixed github.com/mattermost/mattermost-server (Go): 4.3.3, 4.4.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/mattermost/mattermost-server (Go) | before 4.3.3 | 4.3.3 | Patch available | GHSA-hgrp-fgm8-56g8 |
| — | github.com/mattermost/mattermost-server (Go) | 4.4.0-rc1 to before 4.4.3 | 4.4.3 | Patch available | GHSA-hgrp-fgm8-56g8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/mattermost/mattermost-server (Go) Vendor— Affected before 4.3.3 Fixed in 4.3.3 Patch available GHSA-hgrp-fgm8-56g8
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 4.4.0-rc1 to before 4.4.3 Fixed in 4.4.3 Patch available GHSA-hgrp-fgm8-56g8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | before 4.3.3; 4.4.0 to before 4.4.3 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions before 4.3.3; 4.4.0 to before 4.4.3 Vulnerable ·Mattermost
Remediation
- Fix · GHSA-hgrp-fgm8-56g8 github.com/mattermost/mattermost-server (Go) Fixed in 4.3.3 Advisory →
- Fix · GHSA-hgrp-fgm8-56g8 github.com/mattermost/mattermost-server (Go) Fixed in 4.4.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-18872
- 2026-10-03 Alias added: GHSA-hgrp-fgm8-56g8
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2017-18872 · CVE Program
- CVE-2017-18872 · NVD
- FIRST EPSS
- GHSA-hgrp-fgm8-56g8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences