An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2.
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. XSS could occur via the author_link field of a Slack attachment.
Why it matters now
EPSS 0.0069 53rd percentileScored 2026-11-07
Fix Fixed github.com/mattermost/mattermost-server (Go): 4.1.2, 4.2.1, 4.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/mattermost/mattermost-server (Go) | before 4.1.2 | 4.1.2 | Patch available | GHSA-498j-wxww-j897 |
| — | github.com/mattermost/mattermost-server (Go) | 4.2.0 to before 4.2.1 | 4.2.1 | Patch available | GHSA-498j-wxww-j897 |
| — | github.com/mattermost/mattermost-server (Go) | 4.3.0-rc1 to before 4.3.0 | 4.3.0 | Patch available | GHSA-498j-wxww-j897 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/mattermost/mattermost-server (Go) Vendor— Affected before 4.1.2 Fixed in 4.1.2 Patch available GHSA-498j-wxww-j897
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 4.2.0 to before 4.2.1 Fixed in 4.2.1 Patch available GHSA-498j-wxww-j897
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 4.3.0-rc1 to before 4.3.0 Fixed in 4.3.0 Patch available GHSA-498j-wxww-j897
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | before 4.1.2; 4.2.0 to before 4.2.1 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:4.3.0:rc1:*:*:*:*:*:* | 4.3.0 rc1 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:4.3.0:rc2:*:*:*:*:*:* | 4.3.0 rc2 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:4.3.0:rc3:*:*:*:*:*:* | 4.3.0 rc3 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:4.3.0:rc4:*:*:*:*:*:* | 4.3.0 rc4 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions before 4.1.2; 4.2.0 to before 4.2.1 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:4.3.0:rc1:*:*:*:*:*:* Versions 4.3.0 rc1 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:4.3.0:rc2:*:*:*:*:*:* Versions 4.3.0 rc2 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:4.3.0:rc3:*:*:*:*:*:* Versions 4.3.0 rc3 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:4.3.0:rc4:*:*:*:*:*:* Versions 4.3.0 rc4 Vulnerable ·Mattermost
Remediation
- Fix · GHSA-498j-wxww-j897 github.com/mattermost/mattermost-server (Go) Fixed in 4.1.2 Advisory →
- Fix · GHSA-498j-wxww-j897 github.com/mattermost/mattermost-server (Go) Fixed in 4.2.1 Advisory →
- Fix · GHSA-498j-wxww-j897 github.com/mattermost/mattermost-server (Go) Fixed in 4.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-18879
- 2026-10-03 Alias added: GHSA-498j-wxww-j897
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2017-18879 · CVE Program
- CVE-2017-18879 · NVD
- FIRST EPSS
- GHSA-498j-wxww-j897 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences