An issue was discovered in Mattermost Server before 4.2.0, 4.1.1, and 4.0.5.
Priority LOW 26CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
An issue was discovered in Mattermost Server before 4.2.0, 4.1.1, and 4.0.5. It allows attackers to obtain sensitive information (user statuses) via a REST API version 4 endpoint.
Why it matters now
EPSS 0.00927 60th percentileScored 2026-11-07
Fix Fixed github.com/mattermost/mattermost-server (Go): 4.0.5, 4.1.1, 4.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/mattermost/mattermost-server (Go) | before 4.0.5 | 4.0.5 | Patch available | GHSA-h742-xx59-r9pq |
| — | github.com/mattermost/mattermost-server (Go) | 4.1.0 to before 4.1.1 | 4.1.1 | Patch available | GHSA-h742-xx59-r9pq |
| — | github.com/mattermost/mattermost-server (Go) | 4.2.0-rc1 to before 4.2.0 | 4.2.0 | Patch available | GHSA-h742-xx59-r9pq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/mattermost/mattermost-server (Go) Vendor— Affected before 4.0.5 Fixed in 4.0.5 Patch available GHSA-h742-xx59-r9pq
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 4.1.0 to before 4.1.1 Fixed in 4.1.1 Patch available GHSA-h742-xx59-r9pq
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 4.2.0-rc1 to before 4.2.0 Fixed in 4.2.0 Patch available GHSA-h742-xx59-r9pq
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | before 4.0.5; 4.1.0 to before 4.1.1 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:4.2.0:rc1:*:*:*:*:*:* | 4.2.0 rc1 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:4.2.0:rc2:*:*:*:*:*:* | 4.2.0 rc2 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:4.2.0:rc3:*:*:*:*:*:* | 4.2.0 rc3 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:4.2.0:rc4:*:*:*:*:*:* | 4.2.0 rc4 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions before 4.0.5; 4.1.0 to before 4.1.1 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:4.2.0:rc1:*:*:*:*:*:* Versions 4.2.0 rc1 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:4.2.0:rc2:*:*:*:*:*:* Versions 4.2.0 rc2 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:4.2.0:rc3:*:*:*:*:*:* Versions 4.2.0 rc3 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:4.2.0:rc4:*:*:*:*:*:* Versions 4.2.0 rc4 Vulnerable ·Mattermost
Remediation
- Fix · GHSA-h742-xx59-r9pq github.com/mattermost/mattermost-server (Go) Fixed in 4.0.5 Advisory →
- Fix · GHSA-h742-xx59-r9pq github.com/mattermost/mattermost-server (Go) Fixed in 4.1.1 Advisory →
- Fix · GHSA-h742-xx59-r9pq github.com/mattermost/mattermost-server (Go) Fixed in 4.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-18895
- 2026-10-03 Alias added: GHSA-h742-xx59-r9pq
References
Other 5
- https://github.com/mattermost/mattermost/commit/3c34e2b2dcb0fde96a10e68d877aa7d0ab511669
- https://github.com/mattermost/mattermost/commit/722fb1947a2e7395ccf16adce9206736d803a9f3
- https://github.com/mattermost/mattermost/commit/d38328976e2c8bb0fab91e656042a0d8ac37bc76
- https://github.com/mattermost/mattermost
- https://mattermost.com/security-updates
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2017-18895 · CVE Program
- CVE-2017-18895 · NVD
- FIRST EPSS
- GHSA-h742-xx59-r9pq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences