An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2, when Single…
Priority LOW 37CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2, when Single Sign-On OAuth2 is used. An attacker could claim somebody else's account.
Why it matters now
EPSS 0.00789 56th percentileScored 2026-11-07
Fix Fixed github.com/mattermost/mattermost-server (Go): 3.9.2-0.20170714134023-b17fca0d5ee7, 3.10.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/mattermost/mattermost-server (Go) | before 3.9.2-0.20170714134023-b17fca0d5ee7 | 3.9.2-0.20170714134023-b17fca0d5ee7 | Patch available | GHSA-fpcr-4rr5-hpcp |
| — | github.com/mattermost/mattermost-server (Go) | 3.10.0 to before 3.10.2 | 3.10.2 | Patch available | GHSA-fpcr-4rr5-hpcp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/mattermost/mattermost-server (Go) Vendor— Affected before 3.9.2-0.20170714134023-b17fca0d5ee7 Fixed in 3.9.2-0.20170714134023-b17fca0d5ee7 Patch available GHSA-fpcr-4rr5-hpcp
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 3.10.0 to before 3.10.2 Fixed in 3.10.2 Patch available GHSA-fpcr-4rr5-hpcp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | before 3.9.2; 3.10.0 to before 3.10.2 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions before 3.9.2; 3.10.0 to before 3.10.2 Vulnerable ·Mattermost
Remediation
- Fix · GHSA-fpcr-4rr5-hpcp github.com/mattermost/mattermost-server (Go) Fixed in 3.9.2-0.20170714134023-b17fca0d5ee7 Advisory →
- Fix · GHSA-fpcr-4rr5-hpcp github.com/mattermost/mattermost-server (Go) Fixed in 3.10.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-18906
- 2026-10-03 Alias added: GHSA-fpcr-4rr5-hpcp
References
Other 5
- https://github.com/mattermost/mattermost/commit/259ad46f30d0fac2f7c5c14f3b76b2170f7e90c7
- https://github.com/mattermost/mattermost/commit/b17fca0d5ee7557e3df1cf1d1da8bd749859e35f
- https://github.com/mattermost/mattermost/commit/fbc170733e86f09b46ba754dd03304733d2f482f
- https://github.com/mattermost/mattermost
- https://mattermost.com/security-updates
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2017-18906 · CVE Program
- CVE-2017-18906 · NVD
- FIRST EPSS
- GHSA-fpcr-4rr5-hpcp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences