An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2.
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2. XSS could occur via a channel header.
Why it matters now
EPSS 0.0069 53rd percentileScored 2026-11-07
Fix Fixed github.com/mattermost/mattermost-server (Go): 3.9.2-0.20170714014920-312269ad0bd1, 3.10.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/mattermost/mattermost-server (Go) | before 3.9.2-0.20170714014920-312269ad0bd1 | 3.9.2-0.20170714014920-312269ad0bd1 | Patch available | GHSA-42x9-rr3c-gr59 |
| — | github.com/mattermost/mattermost-server (Go) | 3.10.0 to before 3.10.2 | 3.10.2 | Patch available | GHSA-42x9-rr3c-gr59 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/mattermost/mattermost-server (Go) Vendor— Affected before 3.9.2-0.20170714014920-312269ad0bd1 Fixed in 3.9.2-0.20170714014920-312269ad0bd1 Patch available GHSA-42x9-rr3c-gr59
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 3.10.0 to before 3.10.2 Fixed in 3.10.2 Patch available GHSA-42x9-rr3c-gr59
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | before 3.9.2; 3.10.0 to before 3.10.2 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions before 3.9.2; 3.10.0 to before 3.10.2 Vulnerable ·Mattermost
Remediation
- Fix · GHSA-42x9-rr3c-gr59 github.com/mattermost/mattermost-server (Go) Fixed in 3.9.2-0.20170714014920-312269ad0bd1 Advisory →
- Fix · GHSA-42x9-rr3c-gr59 github.com/mattermost/mattermost-server (Go) Fixed in 3.10.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-18907
- 2026-10-03 Alias added: GHSA-42x9-rr3c-gr59
References
Other 5
- https://github.com/mattermost/mattermost/commit/312269ad0bd166174f07f9df7391fce714601600
- https://github.com/mattermost/mattermost/commit/4519b03d95e8bfe1b2f74094673ae1a2f39f6b47
- https://github.com/mattermost/mattermost/commit/a18479df0940be8503c9b88993490741793eba9e
- https://github.com/mattermost/mattermost
- https://mattermost.com/security-updates
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2017-18907 · CVE Program
- CVE-2017-18907 · NVD
- FIRST EPSS
- GHSA-42x9-rr3c-gr59 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences