An issue was discovered in Mattermost Server before 3.7.3 and 3.6.5.
Priority LOW 23CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
An issue was discovered in Mattermost Server before 3.7.3 and 3.6.5. A System Administrator can place a SAML certificate at an arbitrary pathname.
Why it matters now
EPSS 0.00459 39th percentileScored 2026-11-07
Fix Fixed github.com/mattermost/mattermost-server (Go): 3.6.5, 3.7.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/mattermost/mattermost-server (Go) | before 3.6.5 | 3.6.5 | Patch available | GHSA-5ghq-28r7-qwfj |
| — | github.com/mattermost/mattermost-server (Go) | 3.7.0 to before 3.7.3 | 3.7.3 | Patch available | GHSA-5ghq-28r7-qwfj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/mattermost/mattermost-server (Go) Vendor— Affected before 3.6.5 Fixed in 3.6.5 Patch available GHSA-5ghq-28r7-qwfj
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 3.7.0 to before 3.7.3 Fixed in 3.7.3 Patch available GHSA-5ghq-28r7-qwfj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 3.6.0 to before 3.6.5; 3.7.0 to before 3.7.3 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 3.6.0 to before 3.6.5; 3.7.0 to before 3.7.3 Vulnerable ·Mattermost
Remediation
- Fix · GHSA-5ghq-28r7-qwfj github.com/mattermost/mattermost-server (Go) Fixed in 3.6.5 Advisory →
- Fix · GHSA-5ghq-28r7-qwfj github.com/mattermost/mattermost-server (Go) Fixed in 3.7.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-18918
- 2026-10-03 Alias added: GHSA-5ghq-28r7-qwfj
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2017-18918 · CVE Program
- CVE-2017-18918 · NVD
- FIRST EPSS
- GHSA-5ghq-28r7-qwfj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences