Read the docs
TI-2017-14272 Aliases CVE-2017-20206GHSA-7mpm-gf56-q8wv

Appointments <= 2.2.1 - Unauthenticated PHP Object Injection

Priority MEDIUM 50CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.

Summary

The Appointments plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2.2.1 via deserialization of untrusted input from the `wpmudev_appointments` cookie. This allows unauthenticated attackers to inject a PHP Object. Attackers were actively exploiting this vulnerability with the WP_Theme() class to create backdoors.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00735 54th percentileScored 2026-11-07
Fix Fixed Appointments (wpmudev): 2.2.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
wpmudevAppointmentsbefore 2.2.22.2.2Patch availableCNA
  • Appointments Vendorwpmudev Affected before 2.2.2 Fixed in 2.2.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpmudev:appointments:*:*:*:*:*:wordpress:*:*up to 2.2.1Vulnerablewpmudev
  • cpe:2.3:a:wpmudev:appointments:*:*:*:*:*:wordpress:*:* Versions up to 2.2.1 Vulnerable ·wpmudev

Remediation

  • Fix · CNA Appointments (wpmudev) Fixed in 2.2.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-20206
  2. 2026-10-03 Alias added: GHSA-7mpm-gf56-q8wv

References

Sources