Plotly, Inc.
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Plotly, Inc. plotly.js versions prior to 1.16.0 are vulnerable to an XSS issue.
Why it matters now
EPSS 0.00878 59th percentileScored 2026-11-07
Fix Fixed plotly.js (npm): 1.16.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | plotly.js (npm) | before 1.16.0 | 1.16.0 | Patch available | GHSA-2fqv-h3r5-m4vf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- plotly.js (npm) Vendor— Affected before 1.16.0 Fixed in 1.16.0 Patch available GHSA-2fqv-h3r5-m4vf
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:plotly:plotly.js:1.11.0:*:*:*:*:*:*:* | 1.11.0 | Vulnerable | Plotly |
| cpe:2.3:a:plotly:plotly.js:1.12.0:*:*:*:*:*:*:* | 1.12.0 | Vulnerable | Plotly |
| cpe:2.3:a:plotly:plotly.js:1.13.0:*:*:*:*:*:*:* | 1.13.0 | Vulnerable | Plotly |
| cpe:2.3:a:plotly:plotly.js:1.14.0:*:*:*:*:*:*:* | 1.14.0 | Vulnerable | Plotly |
| cpe:2.3:a:plotly:plotly.js:1.14.1:*:*:*:*:*:*:* | 1.14.1 | Vulnerable | Plotly |
| cpe:2.3:a:plotly:plotly.js:1.14.2:*:*:*:*:*:*:* | 1.14.2 | Vulnerable | Plotly |
| cpe:2.3:a:plotly:plotly.js:1.15.0:*:*:*:*:*:*:* | 1.15.0 | Vulnerable | Plotly |
- cpe:2.3:a:plotly:plotly.js:1.11.0:*:*:*:*:*:*:* Versions 1.11.0 Vulnerable ·Plotly
- cpe:2.3:a:plotly:plotly.js:1.12.0:*:*:*:*:*:*:* Versions 1.12.0 Vulnerable ·Plotly
- cpe:2.3:a:plotly:plotly.js:1.13.0:*:*:*:*:*:*:* Versions 1.13.0 Vulnerable ·Plotly
- cpe:2.3:a:plotly:plotly.js:1.14.0:*:*:*:*:*:*:* Versions 1.14.0 Vulnerable ·Plotly
- cpe:2.3:a:plotly:plotly.js:1.14.1:*:*:*:*:*:*:* Versions 1.14.1 Vulnerable ·Plotly
- cpe:2.3:a:plotly:plotly.js:1.14.2:*:*:*:*:*:*:* Versions 1.14.2 Vulnerable ·Plotly
- cpe:2.3:a:plotly:plotly.js:1.15.0:*:*:*:*:*:*:* Versions 1.15.0 Vulnerable ·Plotly
Remediation
- Fix · GHSA-2fqv-h3r5-m4vf plotly.js (npm) Fixed in 1.16.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000006
- 2026-10-03 Alias added: GHSA-2fqv-h3r5-m4vf
References
Advisory 3
More Plotly.js vulnerabilities
- TI-2023-24922 In Plotly plotly.js before 2.25.2, plot API calls have a risk of __proto__ being polluted… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2017-1000006 · CVE Program
- CVE-2017-1000006 · NVD
- FIRST EPSS
- GHSA-2fqv-h3r5-m4vf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences