In Plotly plotly.js before 2.25.2, plot API calls have a risk of __proto__ being polluted…
Priority MEDIUM 51CWE-1321Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
In Plotly plotly.js before 2.25.2, plot API calls have a risk of __proto__ being polluted in expandObjectPaths or nestedProperty.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00936 61st percentileScored 2026-11-07
Fix Fixed plotly/plotly.js (Packagist): 2.25.2plotly.js (npm): 2.25.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | plotly/plotly.js (Packagist) | before 2.25.2 | 2.25.2 | Patch available | GHSA-wjc4-73q6-gv3m |
| — | plotly.js (npm) | before 2.25.2 | 2.25.2 | Patch available | GHSA-wjc4-73q6-gv3m |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- plotly/plotly.js (Packagist) Vendor— Affected before 2.25.2 Fixed in 2.25.2 Patch available GHSA-wjc4-73q6-gv3m
- plotly.js (npm) Vendor— Affected before 2.25.2 Fixed in 2.25.2 Patch available GHSA-wjc4-73q6-gv3m
Remediation
- Fix · GHSA-wjc4-73q6-gv3m plotly/plotly.js (Packagist) Fixed in 2.25.2 Advisory →
- Fix · GHSA-wjc4-73q6-gv3m plotly.js (npm) Fixed in 2.25.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46308
- 2026-10-03 Alias added: GHSA-wjc4-73q6-gv3m
References
Other 7
- https://plotly.com/javascript/
- https://github.com/plotly/plotly.js/releases/tag/v2.25.2
- https://github.com/plotly/plotly.R/issues/2463
- https://github.com/plotly/plotly.js/commit/02498404c8ad7a3395191e65694fb142a37b0fe9
- https://github.com/plotly/plotly.js/commit/5efd2a1f07a418b230a5626fc6c1c7929c47949d
- https://github.com/plotly/plotly.js
- https://plotly.com/javascript
More Plotly.js vulnerabilities
- TI-2017-14353 Plotly, Inc. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2023-46308 · CVE Program
- CVE-2023-46308 · NVD
- FIRST EPSS
- GHSA-wjc4-73q6-gv3m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences