Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can…
Priority MEDIUM 41CWE-59Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Partial Red Hat: 6 fixed, 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository
Why it matters now
EPSS 0.04948 92nd percentileScored 2026-11-07
Fix Partial mercurial (PyPI): 4.3.1Red Hat: 1 advisoryRed Hat: 6 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mercurial (PyPI) | before 4.3.1 | 4.3.1 | Patch available | GHSA-hvr9-wr9p-grgr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mercurial (PyPI) Vendor— Affected before 4.3.1 Fixed in 4.3.1 Patch available GHSA-hvr9-wr9p-grgr
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mercurial:mercurial:*:*:*:*:*:*:*:* | before 4.3 | Vulnerable | Mercurial |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_aus:7.4:*:*:*:*:*:*:* | 7.4 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_aus:7.6:*:*:*:*:*:*:* | 7.6 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_eus:7.4:*:*:*:*:*:*:* | 7.4 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_eus:7.5:*:*:*:*:*:*:* | 7.5 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_eus:7.6:*:*:*:*:*:*:* | 7.6 | Vulnerable | Red Hat |
- cpe:2.3:a:mercurial:mercurial:*:*:*:*:*:*:*:* Versions before 4.3 Vulnerable ·Mercurial
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_aus:7.4:*:*:*:*:*:*:* Versions 7.4 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_aus:7.6:*:*:*:*:*:*:* Versions 7.6 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_eus:7.4:*:*:*:*:*:*:* Versions 7.4 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_eus:7.5:*:*:*:*:*:*:* Versions 7.5 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_eus:7.6:*:*:*:*:*:*:* Versions 7.6 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-hvr9-wr9p-grgr mercurial (PyPI) Fixed in 4.3.1 Advisory →
Red Hat 1 advisory
- RHSA-2017:2489 Released 2017-08-17 · Red Hat rating Importantmercurial security update
- Red Hat Enterprise Linux Client Optional (v. 7) emacs-mercurial-2.6.2-8.el7_4, emacs-mercurial-el-2.6.2-8.el7_4, mercurial-2.6.2-8.el7_4 +1
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) emacs-mercurial-2.6.2-8.el7_4, emacs-mercurial-el-2.6.2-8.el7_4, mercurial-2.6.2-8.el7_4 +1
- Red Hat Enterprise Linux Server (v. 7) mercurial-2.6.2-8.el7_4
- Red Hat Enterprise Linux Server Optional (v. 7) emacs-mercurial-2.6.2-8.el7_4, emacs-mercurial-el-2.6.2-8.el7_4, mercurial-hgk-2.6.2-8.el7_4
- Red Hat Enterprise Linux Workstation (v. 7) mercurial-2.6.2-8.el7_4
- Red Hat Enterprise Linux Workstation Optional (v. 7) emacs-mercurial-2.6.2-8.el7_4, emacs-mercurial-el-2.6.2-8.el7_4, mercurial-hgk-2.6.2-8.el7_4
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2017:2489 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2017:2489 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2017:2489 |
| Red Hat Enterprise Linux Server Optional (v. 7) | Fixed | RHSA-2017:2489 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2017:2489 |
| Red Hat Enterprise Linux Workstation Optional (v. 7) | Fixed | RHSA-2017:2489 |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000115
- 2026-10-03 Alias added: GHSA-hvr9-wr9p-grgr
References
Advisory 5
Sources
- CVE-2017-1000115 · CVE Program
- CVE-2017-1000115 · NVD
- FIRST EPSS
- GHSA-hvr9-wr9p-grgr · GitHub Advisory Database · CC BY 4.0
- CVE-2017-1000115 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences